7657 questions

9091 answers

14651 comments

12043 members

0 votes
214 views 2 comments
by
Hello,

want to attach a LED as a remote power indicator. The router RUT955 is built into a cabinet and I want to see from outside whether the router is running or not. I connected the operating voltage Vcc = 12 V via a resistor of 1 kOhm and the LED to pin 4 of 4 pin connector. I could turn the LED on and of by toggling the button "Turn on" resp. "Turn off" in the Output section of WebUI. So in principle from electrically point of view it works.

Now I want to make this state persistent, means, when I switch the router RUT955 on, the LED automatically should also be on (shining) without any interaction via WebUI.

How to do this?

Thanks in advance for any answer.

BR Günther

1 Answer

0 votes
by

Hello Günther,

Go to router Services -> Input/Output -> Output -> Output configuration and change "Digital output 4PIN" default state to "High level". After router reboot, this configuration will be activated and pin default state will be "On" and when router powered your LED will be lit. 

Best regards,

Tomas

Best answer
by

Hello Tomas,

this is completely correct and I got it working now; yet I have been stumbling over two issues which might be of interest for all:

  1. When pressing "Save" the configuration does not come into effect immediately as for other parameters; one has to reboot the router resp. switch it off and on again to persist the configuration,
  2. When connecting some circuitry to an open collector output one assumes an electrically low level (0 Volt) as the active state; therefor the terms "High level" resp. "Low level" in the list box of the configuration panel are a bit misleading; the reverse assignment would be closer to the de facto electrical behaviour.
Have many thanks for your support.
Bye
Günther
by
Hello,

I have informed RnD about this situation and in future firmware releases additional information would be added.