10908 questions

12999 answers

20267 comments

26732 members

0 votes
1,265 views 1 comments
by

Router: RUT240

FW: RUT2XX_R_00.01.11.1


Hello there! Asking to see if someone has the similar issue or can relate:

I just updated to the latest FW RUT2XX_R_00.01.11.1, in order to being able to use ZeroTier VPN as with RUT9XX series. FW upgarde went OK. I now have the Package Manager feature and proceeded to install ZeroTier package ver. 1.1.14. Next I followed the following procedure:
 

  1. Services → VPN → ZeroTier tab → ZeroTier General:
    1. click Enable
    2. enter NetworkID in field
    3. clic save
  2. Copy generated RUT240 ZeroTier client address
  3. Login into the ZeroTier's dashboard and authorize former client address.

After authorizing, I lost LAN connectivity, I mean, I couldnl't access WebUI, SSH or ping the RUT240 from within our private network.
I couldn't also access it using its ZeroTier VPN IP address.

I rebooted the router with an SMS command. Then I had time to disable the ZeroTier, but if I wait enough I could then again lost LAN access.

Another thing I tried is:

Activating in the tab Services → VPN → ZeroTier tab → ZeroTier VPN the "Enable VPN" option and setting it in client mode selecting the corresponding network id.
It also failed.

Since I lost SSH access I cannot login to view  interfaces/routes/etc config.

Where should I look for more info?

Could this be a bug?

Many thanks in advance!

1 Answer

0 votes
by

Hello.

We extensively tested the ZeroTier functionality in multiple scenarios and we haven't got such behavior. Indeed I'm writing you now from a PC connected to a RUT240 + Zerotier Enabled with no problem.

You can follow the link below to get more instructions about how the Functionality is implemented

https://wiki.teltonika.lt/view/ZeroTier_One_VPN_configuration

Can you please restore the device to factory settings and install the Zerotier Package again?

Keep in mind that some times Zerotier servers take a while to update the connection after the device reboots.

Also. keep in mind that sometimes the ZerotierServers closes the connection of some devices if it doesn't send information after 120 seconds.

You can force the device to send and thus keep the Zerotier enabled by using this User Script. Use it in the client and server devices. Please remember substitute the IP in the example with the Zerotier Server IP or the IP of any other device in your same Zerotier Network.

https://wiki.teltonika.lt/view/RUT240_User_Scripts

#!/bin/ash
while [ 1 ]; do
ping 10.147.17.225 -c 3 -q >/dev/null
ret=$?
if [ $ret -ne 0 ]; then
/etc/init.d/zerotier restart
fi
sleep 60
done

If the problem persists please reach out to your Sales Manager and provide a troubleshoot file and a TCP dump file to track further why is presenting such behavior.

Best answer
by

Thanks a lot for such detailed and fast answer!!

I tried creating a new ZeroTier network and this time it worked flawlessly. So maybe it could be some config issue in our current ZeroTier network

I also noticed that, as you said, after some minutes without activity I was disconnected from ZeroTier. Funny thing is we operate our production network with ZeroTier and is the first time I see a disconnection (we have a lot of low/no activity clients). But all of our clients have ZT versions 1.2.x ~ 1.4.x. Do you think Teltonika's ZeroTier package version 1.1.14 could be the reason of this disconnections? In the ZeroTier dashboard the version is highlighted as red. (see below)

Anyway, I could try your provided script. 

Many thanks for the clarification!!!