10417 questions

12418 answers

19281 comments

21748 members

+1 vote
1,682 views 12 comments
by
  • FW ver.: RUT9XX_R_00.06.04.5

My gps module shows me incorrect date, so my gps data can't correctly sent to the server. cause date and time currenlty shows me 2000-03-25 11:05:58 i don't understand how to fix it, the date and time in the device is correct, only GPS fix time setting is incorrect

by
I have a similar problem: when the correct timezone is set in Services -> NTP -> General, the GPS starts to return wrong time (both formatted datetime and the timestamp)

1 Answer

0 votes
by
Hi,

Could you add screenshot from router WebUI where you see these details?

Also, could you add screenshot with output from SSH/CLI using command:

gpsctl -tpse
Best answer
by

Sure, pictures with details of my issue

I thought and blame GPS antenna,but connect another one, and problem still here.

by
Hmm, basically router shows data which it get from satellites..

Try to reinstall router firmware to latest release: https://wiki.teltonika.lt/view/RUT9xx_Firmware

If you have possibility, try do not keep old settings (before this download a backup file from router).
by
I have seen similar issue. Related to GPS rollover? Also, can't manually set date from CLI when gpsd is running on RUT955. Have sent email to Teltonika regarding issue.
by
i have updated to last possible firmware, and reset all settings, it didn't help. Yeah, that's the problem i can't edit time, btw it's strange but we have 3 similar devices, 2 of 3 have this issue and last one didn't. First time i be sure that problem could be with gps antena, but when i connected original gps antena which was in teltonika pack, nothing changed. Also i thought that fresh firmware could be a problem, and again it's not. For this moment i have  RUT9XX_R_00.06.04.5 firmware and 3.0.1 bootloader
by
Thank you for your notes. We will check this (#835).
by
also i wanna add comment that we had been using this three routers RUT955 at least 3-4years and all worked good. We notice this problem cause we stop received gps data from the our GPS tracking system WIALON/GURTAM. I don't know the reason, it could be firmware update or something else.
by
do you have suggestions to solve my problem?
by
Hello,

Can you provide your routers product code?
by
Can you send it to the admin@amid.kz, cause I can't access because I've got "502 bad gateway" error
by
hallelujah, it works! Thank you Vytautas! BUT! UTC 0h timezone, and not my +6h