7141 questions

8568 answers

13830 comments

10608 members

0 votes
377 views 1 comments
by
We are unable to perform configuring actions with RUT230 (v.1.11.1) in WebUI via IPSec using Ubuntu 19.04, but with WiFi or wired it works. We have tried with Chrome and Firefox. You can navigate in the web interface perfectly fine, but you can't e.g. add new lines to Routing config or delete them or save changes in any page. Inspector reveals the page just hangs on 'pending' on site document. In Chrome, 20 minute wait ends up in HTTP error 502 and in Firefox it takes couple minutes until the page stops at "Secure Connection Failed". This was tested on more than one computer.

Now, everything works on Windows 10. We tried IE, Chrome, Firefox, all of them work via IPSec. We are using the same IPSec connection in both environments.

We have many Linux users and booting to Windows every now and then just to change couple lines through WebUI is not ideal. Is this a known issue and are there any suggestions what actions we should take to correct this issue?

EDIT: I think I should point out that we use strongSwan on Linux server to act as a gateway between clients. We aren't directly connecting to RUT230.

1 Answer

0 votes
by

Hello,

can you try to insert these firewall rules to RUT230?

iptables -t mangle -I FORWARD -m policy --pol ipsec --dir in -p tcp -m tcp --tcp-flags SYN,RST SYN -m tcpmss --mss 1361:1536 -j TCPMSS --set-mss 1360
iptables -t mangle -I FORWARD -m policy --pol ipsec --dir out -p tcp -m tcp --tcp-flags SYN,RST SYN -m tcpmss --mss 1361:1536 -j TCPMSS --set-mss 1360
by
Hi,

thanks for your reply. I added these rules under Custom Rules and rebooted our RUT230. Unfortunately, they had no effect.