5747 questions

6968 answers

11237 comments

7062 members

0 votes
776 views 1 comments
by
Hi everyone,

Could anyone of you please share with me the DMVPN configuration of a CISCO (HUB) and RUT955 (SPOKE) because I am trying for a few days now and I am unsuccessful, I have all the configs as illustrated by the manual but it still doesn't work.

Are there any compatibility issues with having a cisco hub and a rut955 spoke?

If anyone has a full example of a similar scenario share with me please

Can you please help?

I would appreciate

Thanks

2 Answers

0 votes
by

Hello, 

Please check link below:
https://wiki.teltonika.lt/view/DMVPN_configuration
 

0 votes
by

Dear Jose,

Enter to the configuration mode on the Cisco Hub CLI then just enter this configuration 
Just replace the interface if your using a different interface. 

-----------------------------------

interface Tunnel0

description mGRE - DMVPN Tunnel

ip address 10.1.1.1 255.255.255.0

ip nhrp network-id 1

ip nhrp nhs dynamic nbma multicast

ip nhrp shortcut

ip nhrp redirect

tunnel source GigabitEthernet0/0/1             

tunnel key 1234

tunnel protection ipsec profile DMVPN

---------------------------------------------------------

router bgp 65001

bgp log-neighbor-changes

network 10.1.1.0 mask 255.255.255.0

neighbor spokes-ibgp peer-group

neighbor spokes-ibgp remote-as 65001

neighbor spokes-ibgp route-reflector-client

neighbor spokes-ibgp soft-reconfiguration inbound

neighbor 10.1.1.3 peer-group spokes-ibgp

neighbor 10.1.1.2 peer-group spokes-ibgp

---------------------------------------------------------------

And follow the configuration on this links : 

https://wiki.teltonika.lt/view/DMVPN_configuration#Spoke_configuration:_DMVPN
https://wiki.teltonika.lt/view/DMVPN_configuration#Spoke_configuration:_BGP

Note: Please make sure you will input the LAN IP of the spoke. 

Regards,
Jerome

by
Thank you for you answer Jerome,

But this cisco hub configuration doesn't contain the ipsec configuration part, and I can't set up a DMPVN on my RUT955 without a ipsec configuration.

Please if you already made this and it's working perfetcly share with me your entire configuration, I would appreciate

Best Regard,

Jose Luis.