subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
627 views 2 comments
After I upgraded my RUTX08 to RUTX_R_00.02.00.2 from 1. something version my Open VPN tls client config stopped working. I have tracked this to that it no longer uses the extra options in which i have "topology subnet". Default for open vpn is p2p and this causes the connection to fail as the ip config recived from the server is invalid for that mode.

I have currently worked around this by adding push "topology subnet" to this clients CCD file on the server.

So my question is why aren't the extra options being used in this firmware version ?

1 Answer

0 votes
by anonymous

So is the OpenVPN client config not working or the TLS client in the server's config? Can you try deleting the TLS client and adding it over again (maybe there was a keep settings issue with the FW upgrade)? Because it seems to work for me.

It is the client config that stopped working after the upgrade(on a RUTX08).

I tried creating a new client config on the RUTX08 but that would still not work, the extra options in the openvpn client config are no longer used (or the topology is somehow overwritten). 

For my client to be able to connect is has to have "topology subnet" or else the client will exit on the ip config it receives from the server.

This error message is shown in the system log on the RUTX08 which shows that the option "topology subnet" is never used.

WARNING: Since you are using --dev tun with a point-to-point topology, the second argument to --ifconfig must be an IP address.  You are using something ( that looks more like a netmask. (silence this warning with --ifconfig-nowarn)

For now I will have to push this option to this specific client from the server to make it work.

This is the option that was working in 1.x but not in 2.x


I looked in the openvpn config file with the cli and this is what the extra option looked like. (Isn't it supposed to be "option")

option client '1'
list _extra 'topology subnet'
option enable '1'