7572 questions

9026 answers

14571 comments

11782 members

0 votes
249 views 0 comments
by
On start up the first position sent by the TRB142 is a position in Estonia. Even if i use the 'Default NMEA Position' field in the NTRIP configuration the modems still reports this position. Why is this and can we edit it somehow? This seems to occur on all Firmware versions. Once the reciever starts sending GGA to the TRB142's serial port it does send the correct position, however, until this happens it sends the Estonia position which causes issue with NTRIP casters operating on a 'Nearest Base' system.

1 Answer

0 votes
by

Hello,

How GGA sentence looked when you entered it? Does it had '$' sign in front, for example: $GPGGA,050016.249,5542.884,N,02421.072,E,1,12,1.0,0.0,M,0.0,M,,*61? Since this can cause an issue. If it had, then try to reach gateway terminal via SSH and manually edit rs232 default GGA NMEA sentence. This can be done in several ways:

  1. Using VI editor, go to /etc/config/rs and edit GGA sentence for rs232 option ntrip_nmea;
  2. Using uci commands (more information about uci: https://wiki.teltonika-networks.com/view/UCI_command_usage). Enter these three commands in terminal and default GGA sentence will be changed:
    1. uci set rs.rs232.ntrip_nmea='$GPGGA,050016.249,5542.884,N,02421.072,E,1,12,1.0,0.0,M,0.0,M,,*61' Note: change GGA sentece to your own and make sure that single quotes are in front and back of your sentence
    2. uci commit rs
    3. luci-reload
    4. After your enter these three commands, GGA sentence will be changed and you can check it with this command uci get rs.rs232.ntrip_nmea