8752 questions

10398 answers

16334 comments

15446 members

+3 votes
1,545 views 17 comments
by
Hi, I just bought RUTX11 recently which come with 00.02.00.1 firmware. During configuration phase I managed to update device FW to 00.02.01.1 version, and modem FW to EG06ELAR03A05M4G. Since then my GPS stopped working (gpsctl -d Fail to find gpsd ubus object). I've managed to fix issues with the GPS following community page by installing provided in different post T_F0992_00.02.02.982_WEBUI. It just fixed GPS issues but from now on my RUTX11 start blinking 2/3/4G LED - while previously it was lit solid green. I was trying to figure out what is the difference between solid vs blinking led and cant really figure that out at there is no LED statuses description available. I have to say that I preffer solid led rather than blinking one as router is placed just in front of me and blinking led draws my attention. The other issue I've got is I can't update the firmware to the EG06ELAR04A03M4G version. As one of these updates broke ability to install updates and new modem FW contains few important fixes can you provide a way to manually update modem in RUTX11 device until you provide working update release which doesn't break everything ? Also, is there a way to switch Mobile Network LED behaviour to lit solid ?

Regards,

Greg
by
Curious but how can you update the modem FW separately? I assumed the RUTX FW itself may come with and perform a Modem FW. Seems it's separate?
by
It is possible via file update not fota.
by
Where can i get file modem firmware to update to version EG06ELAR04A03M4G ?

I updated from server, it download but there are problem when update

Thanks
by
Seeing the same problem trying to upgrade from EG06ELAR03A05M4G to EG06ELAR04A03M4G

https://community.teltonika-networks.com/16933/rutx11-modem-upgrade-fails?show=16933#q16933

2 Answers

0 votes
by
Hello,

What error message you are getting, when you try to install that modem software version?
by
Basically it's downloaded till the 100% and that's it. The firmware doesn't want to install. Nothing happens at the end. So maybe there is the way to install it manually vie file installation?
by

Previously, when things was less broken, when I choose modem firmware update from the server files were downloaded up to 100% and when I click proceed it quickly display update failure or something similar and redirect to the FW upgrade page. I was able to copy package from /tmp/modemfw to USB drive. Right now while I'm on  FW VER: RUTX_T_F0992_00.02.02.982, whenever I hit modem firmware update it just stuck on 0% download and nothing happens. 

Considering I've got full file set with modem firmware I'd like to know how to update it manually. Please advise.

Greg

by
How do you able to copy the fw to the usb?

Can you share the file?
by
Well, personally I think this files should be provided by Teltronika not by me. Never trust firmware files downloaded from random people over internet :) But seriously, If you are able to trigger FOTA Modem FW upgrade process which will fail after 100% you're able to copy files downloaded from the server.
by
As i mentioned above, the process stacks at 100%. And that's it(.
0 votes
by

Finally with the support of community (not Teltronika) I was able to flash modem FW upgrade myself through CLI. The secret command that can't be provided by the Teltronika support is:

root@TELET4:~# /usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A03M4G/ -p /dev/ttyUSB0

[000.000] QFirehose Version: LTE_QFirehose_Linux&Android_V1.0.3

[000.000] Builded: Feb 27 2020 21:25:59

[000.000] qusb_noblock_open port_name = /dev/ttyUSB0

[000.001] P: /dev/bus/usb/003/002 idVendor=2c7c idProduct=0306

[000.001] C: /dev/bus/usb/003/002 bNumInterfaces: 5

[000.001] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff

[000.001] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms

[000.001] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms

[000.001] I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00

[000.001] I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00

[000.001] I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00

[000.001] I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff

[001.004] poll_wait events=POLLIN msec=1000 timeout

[001.004] qusb_noblock_read cur=0, min_size=1

[001.004] switch to 'Emergency download mode'

[001.005] successful, wait module reboot

[001.027] qusb_noblock_read cur=0, min_size=1

[002.304] qusb_noblock_open port_name = /dev/ttyUSB0

[002.305] P: /dev/bus/usb/003/003 idVendor=05c6 idProduct=9008

[002.305] C: /dev/bus/usb/003/003 bNumInterfaces: 1

[002.305] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff

[002.305] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms

[002.305] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms

[002.305] prog_nand_firehose_filename = prog_nand_firehose_9x45.mbn

[002.305] STATE <-- SAHARA_WAIT_HELLO

[002.306] RECEIVED <--  SAHARA_HELLO_ID

[002.306] RECEIVED <-- SAHARA_MODE_IMAGE_TX_PENDING

[002.306] SENDING --> SAHARA_HELLO_RESPONSE

[002.306] STATE <-- SAHARA_WAIT_COMMAND

[...]

[002.362] Sahara protocol completed

[003.365] <log value="Binary build date: Apr 13 2018 @ 09:51:57"/>

[003.366] <log value="Supported Functions: program configure power benchmark read getstorageinfo erase nop "/>

[004.404] <configure MemoryName="nand" Verbose="0" AlwaysValidate="0" MaxDigestTableSizeInBytes="2048" MaxPayloadSizeToTargetInBytes="8192"  ZlpAwareHost="1" SkipStorageInit="0" />

[...]

[009.152] send finished

[009.153] <log value="Finished sector address 11328"/>

[009.153] <response value="ACK" rawmode="false" />

[009.153] <program PAGES_PER_BLOCK="64" SECTOR_SIZE_IN_BYTES="4096" filename="..\rpm.mbn" num_partition_sectors="39"  physical_partition_number="0" start_sector="12096" />

[009.154] <log value="INSIDE HANDLE PROGRAM"/>

[009.154] <log value="start_sector 12096, last_sector_address 12135"/>

[009.154] <response value="ACK" rawmode="true" />

[009.154] send ../rpm.mbn, filesize=157400

[009.207] send finished

[009.208] <log value="Finished sector address 12096"/>

[009.208] <response value="ACK" rawmode="false" />

[009.208] <program PAGES_PER_BLOCK="64" SECTOR_SIZE_IN_BYTES="4096" filename="..\appsboot.mbn" num_partition_sectors="124"  physical_partition_number="0" start_sector="12864" />

[009.209] <log value="INSIDE HANDLE PROGRAM"/>

[009.209] <log value="start_sector 12864, last_sector_address 12988"/>

[009.209] <response value="ACK" rawmode="true" />

[009.209] send ../appsboot.mbn, filesize=504522

[009.376] send finished

[009.379] <log value="Finished sector address 12864"/>

[009.379] <response value="ACK" rawmode="false" />

[009.379] <program PAGES_PER_BLOCK="64" SECTOR_SIZE_IN_BYTES="4096" filename="..\mdm9640-perf-boot.img" num_partition_sectors="1605"  physical_partition_number="0" start_sector="13632" />

[009.380] <log value="INSIDE HANDLE PROGRAM"/>

[009.380] <log value="start_sector 13632, last_sector_address 15237"/>

[009.380] <response value="ACK" rawmode="true" />

[009.380] send ../mdm9640-perf-boot.img, filesize=6572032

[009.778] Upgrade progress:   1

[010.557] Upgrade progress:   2

[011.336] Upgrade progress:   3

[011.576] send finished

[011.577] <log value="Finished sector address 13632"/>

[011.577] <response value="ACK" rawmode="false" />

[011.577] <program PAGES_PER_BLOCK="64" SECTOR_SIZE_IN_BYTES="4096" filename="..\NON-HLOS.ubi" num_partition_sectors="11520"  physical_partition_number="0" start_sector="16512" />

[011.578] <log value="INSIDE HANDLE PROGRAM"/>

[011.578] <log value="start_sector 16512, last_sector_address 28032"/>

[011.578] <response value="ACK" rawmode="true" />

[011.578] send ../NON-HLOS.ubi, filesize=47185920

[012.114] Upgrade progress:   4

[012.894] Upgrade progress:   5

[013.673] Upgrade progress:   6

[014.453] Upgrade progress:   7

[015.234] Upgrade progress:   8

[016.017] Upgrade progress:   9

[016.796] Upgrade progress:   10

[017.575] Upgrade progress:   11

[018.353] Upgrade progress:   12

[019.133] Upgrade progress:   13

[019.912] Upgrade progress:   14

[020.690] Upgrade progress:   15

[021.468] Upgrade progress:   16

[022.250] Upgrade progress:   17

[023.029] Upgrade progress:   18

[023.807] Upgrade progress:   19

[024.586] Upgrade progress:   20

[025.368] Upgrade progress:   21

[026.147] Upgrade progress:   22

[026.928] Upgrade progress:   23

[027.314] send finished

[027.316] <log value="Finished sector address 16512"/>

[027.317] <response value="ACK" rawmode="false" />

[027.318] <program PAGES_PER_BLOCK="64" SECTOR_SIZE_IN_BYTES="4096" filename="..\mdm9640-perf-boot.img" num_partition_sectors="1605"  physical_partition_number="0" start_sector="35200" />

[027.318] <log value="INSIDE HANDLE PROGRAM"/>

[027.319] <log value="start_sector 35200, last_sector_address 36805"/>

[027.319] <response value="ACK" rawmode="true" />

[027.320] send ../mdm9640-perf-boot.img, filesize=6572032

[027.710] Upgrade progress:   24

[028.493] Upgrade progress:   25

[029.274] Upgrade progress:   26

[029.517] send finished

[...]

[086.779] send ../sbl1.mbn, filesize=234428

[086.855] Upgrade progress:   100

[086.858] send finished

[086.860] <log value="Finished sector address 0"/>

[086.861] <response value="ACK" rawmode="false" />

[086.861] <power value="reset" />

[086.861] <log value="Inside handlePower() - Requested POWER_RESET"/>

[086.861] <response value="ACK" />

[087.862] inf[0] ep_in -1/1024, errno = 71 (Protocol error)

[087.862] qusb_noblock_read read=-1, errno: 71 (Protocol error)

[087.862] qusb_noblock_read cur=0, min_size=1

[087.862] firehose_protocol.c fh_recv_cmd 291 fail

[087.862] THE TOTAL DOWNLOAD TIME IS 85.557 s

[087.862] Upgrade module successfully.

root@TELET4:~# reboot

After all UI shows newest FW installed:

However, this blinking LED still annoys me. Can you tell me how 2G/3G/4G LED behave when modem is attached to the network on your modem ? My used to lit solid, but now it's blinking all the time.

Regards,

Greg

by
can you share the file? please?
by

So regarding the Mobile network type LED's.

* When one of the LED's light up, it shows to which network it is connected.
* When more than one LED blinks at the same time, it means that you need to insert SIM or you wrote the wrong PIN in WebUI.
* If for example, 3G blinks, then 4G, then 3G and so on, it means that it is connecting.
* If one of the LED's blink, it means that the router successfully connected to the operator, but it still hasn't got IP.

Regarding the modem firmware, that feature which allows you to update the modem FW via WebUI did not work for you, because that software is still a demo version. Some functionalities don't work on it yet.

It is not recommended to change the modem FW on your device. Unless there is a reason for it.

by

Modem FW update didn't work since upgrade to official release to 00.02.01.1 version, additionally this upgrade broke GPS functionality hence I had to install RUTX_T_F0992_00.02.02.982 to fix GPS issues you broke with official release. Modem FW upgrade doesn't work for me (and as I can tell for other people) since official release 00.02.01.1. The reason behind I wanted to upgrade modem is vendor fixes which were currently published. It sounds like - you don't have to install windows security updates since your PC working fine. I've managed to update it myself. Please release proper FW upgrade which doesn't broke basic functionalities on the system then I switch from 'demo' FW. 

According to the LED's - They used to lit solid before I've updated to RUTX_T_F0992_00.02.02.982. Whenever my modem attach to the network (either 3g or 4g)  appropriate LED blinking - even when IP address is assigned and everything working fine. It just annoys me, as I'm in 3 square meters room having router in front of me and got this led blinking continiously. Does it have something to do with a different version of the /usr/bin/ledman you're using on 'demo' firmware ?

by

Obviously there are certain reasons to update the mofem firmware to the newest release. Just to name few:

  • Added a new value of 0xFFFE for parameter <bandval> and 0x7FFFFFFFFFFFFFFE for <ltebandval> of AT command AT+QCFG="band" to enable the module to restore the factory settings of supported bands.
  • Added cell lock functionality and command AT+QCELLLOCK to lock cells automatically.
  • Solved the problem that no cell information and network standard report of command AT+CGREG from fixed 4G to 3G.
  • Solved the problem of returning incorrect temperature thresholds after configuring them via AT command AT+QCFG="thermal/modem".
  • SMS Expanded SMS storage size. 
  • Solved the problem of report error when there is no SIM card unlocking PN via AT command AT+QSIMLOCK.
  • Expanded the APN characters of AT command AT+QICSGP to 63. 
  • Solved the problem that the AT command AT+COPS had no return value
I see no reason to deny update for end users. Also it has been reported few times that you're official FW release broke so many things like GPS, firmware update etc. Is there any plans to release firmware which doesn't break basic functionality of the device and fix broken issues introduced by latest released fw ?  
Regards
Greg
by
Regarding the LED's - I have consulted with R&D and they told me that in the demo software you are using, LED operating principle was changed, but when the final version will be released, those will work as before.

New RUTX software will be released in about 2 weeks.

Regarding modem software, although it shows that there is a new software, but is not available yet. I am sure that this will be fixed soon.
by
Thanks for response justinasm. I'm waiting for new firmware release then, hopefully it will solve all the issues and I could come back to release track.

Regards,

Greg
by
Hello,

We have released a new RUTX_R_00.02.03.1 firmware version. The issue with the modem FW update feature is fixed in that software.

You can download that software from our Wiki website, or through the router itself.
by
Thanks, thats finally solved my problem with annoying blinking led. Lifesaver !