4452 questions

5471 answers

8586 comments

5378 members

+1 vote
949 views 16 comments
by


We have upgraded the RUT950 router firmware to the latest RUT9XX_R_00.06.06.1 as suggested. This defaulted the router so we had to reconfigure everything from scratch including VPN connections.
However, after power cycling, Mobile Data connection state sits at Disconnected. The signal is all there but won't connect to network. The mobile network only works after we switch between SIM 1 & 2 from the web interface. This will virtually render the router useless as someone has to physically go over to the router and switch the SIM.

by

TL,DR: 

Option 1) Downgrade to 06.05.3, make sure Mobile Data is working, Upgrade again to 06.06.1.

Option 2) run uci set network.ppp.disabled=0  and uci set network.ppp.enabled=1

Hey there. Same problem here. Brand new RUT955 with with 06.06.1 FW shipped can NOT establish a data connection using the sim. 

Downgrading to 06.05.3 instantly fixes the problem. 

Our SIM is part of a private VPN provider (o2 M2M Solution), so we are not even getting an IP with the latest Firmware.

Country: Germany, Network Provider: O2 / Telefonika

Custom APN, using PPP and PAP. CHAP is not working either. QMI / NDIS is not supported AFAIK from our provider.

We also have an older RUT955, which we recently updated to 06.06.01 and the connections works fine.

After the working connection using the 06.05.* FW on our brand new model, I updated again to 06.06.01 and magically the connections works too!After the upgrade back to 6.06.01 the connection works for a couple of minutes, it stops and is not able to start again. So maybe the upgrade path is necessary / the factory firmware is missing something in 06.06.01 what 06.05 had?

3 Answers

0 votes
by

Hello,

please generate a troubleshoot file when the mobile internet is down and send it to me via private message. Go to System -> Administration -> Troubleshoot and click Download.

Having the troubleshoot file I will see more information and your current configuration.

by

Have you tried inserting another SIM card into the router or inserting the same SIM card into the phone and checking its operation?

Additionally, you should also check the LTE network parameters (RSRP, RSRQ, SINR and RSSI). If any of these indicators do not meet the standarts, then you may face internet issues. More parameters are used to determine the overall quality of the connection. They can be checked in the Status → Network → Mobile page. (Reference to that is here.)

If it does not meet the standards, then you need to check the antenna for proper screwing. If you are using a single antenna, then make sure it is connected to the MAIN antenna connector. The MAIN and AUX connections can be identified by this link.

by
I have added a second "SIM 2" card and I have tested the existing "SIM1" card on another device. SIM1 works fine on another device and SIM 2 doesn't not yield any improvement when used with the RUT955. So I exclude a SIM card problem.

I have also checked all the antennas as advised, but there is also no improvement here. I wanted to point out that my current configuration had worked perfectly - and I was able to surf the Internet just fine - until I mad the "mistake" of upgrading to the latest firmware. This is where the problem started, i.e. the SIM card and the antennas where not touched during this process.

I have also checked the network parameters and:

a) I see that RSRP is at -92 dBm for SIM1 and at -93 dBM for SIM 2. Given the reference link, this seems to be bad. But bear in mind that before the software upgrade (and without having physically touched the Routers, SIM or antennas) the system was working

b) I could not find the SINR though. I am sending the screenshots of network parameters for SIM1 and 2 per private message.
by

Here is an update to everyone who has been reading this. As stated, I have had problems with mobile connection of my RT955 using German Deutsche Telekom SIM card after I had installed  RUT9XX_R_00.06.06.1 | 2020.03.12 Firmware. (see discussion above)

I had always assumed that it was a firmware problem, since the router worked fine prior to the update and I had not altered or touched the physical configuration. 

I have now downgraded to Firmware RUT9XX_R_00.06.05.3 | 2019.11.26 and the Router works perfectly fine again.

So I wonder why 06.06.1 gave such difficulties in my setup and 06.05.03 does not.

I used the Setup Wizard in both firmware installations and did not modify any parameter set by the respective firmwares apart from entering the SIM card pin initially.

From my experience, for the moment I would not advise to upgrade to Firmware 06.06.1 if you have an RT955 operating in Germany using a Deutsche Telekom SIM card.

by
A really strange situation. Maybe you have another mobile operator's SIM card to try with the latest firmware?
by

I have an out of the box RUT950 that I have had to downgrade to RUT9XX_R_00.06.05.1to get any SIM card (UK) to pass mobile data.

If I upgrade to latest firmware, the same SIMs stop connecting.  I would like to have this on the latest firmware before deploying live, but cannot apply those and have it working.  Is the bootloader out of date? Howe can I find out what the latest bootloader is?

details:

Firmware version RUT9XX_R_00.06.05.1
Firmware build date 2019-11-15, 11:43:07
Kernel version 3.18.44
Bootloader version 3.2.5
0 votes
by
Hello, Ashishs,

I see you have an old version of the bootloader so you should upgrade the bootloader. I have sent you the latest version of the bootloader in a private message. Instruction how to upgrade the bootloader you can read here:

https://wiki.teltonika-networks.com/view/RUT9xx_Bootloader_Upgrade
by
Got same problem what is latest bootloader
by

Try installing an older firmware version and checking the internet. All firmware versions can be found here.

by
I am having exactly the same problem with our RUT950, if the router is powered down or rebooted the modem status shows disconnected but the mobile operator details are all populated. The only way to get a connection is to use, modem reboot button in webui and this does not always work first time round. I cannot post a troubleshoot file as I am 20 miles away but from the RMS I can see some historic data and I am using the latest firmware , the bootloader is v 3.2.1, the mobile signal was -59dBm and the router was up for 29 days before a power outage. I am using an unlimited contract data sim from EE. I will need to visit site tomorrow to regain an internet connection but this issue is really frustrating as I have to drive 20 miles to fix and it is running a CCTV system on a farm, so it is essential that it works efficiently.

Any help would be appreciated.

Steve
by
Hello Steve,

Maybe you could send the serial number of the router via private message? Also, if you have a troubleshoot file, please also send it to me for more detailed information.
0 votes
by
I had a similar problem with my 950. Even though the mobile carrier showed up in the overview as connected it wouldn't connect.

I solved this by going to Mobile/Sim Management and unchecked Auto APN. I then put in a customised APN from the Mobile Carriers website.