7572 questions

9025 answers

14571 comments

11781 members

0 votes
565 views 2 comments
by

Hi,

I've been running my RUTX09 in bridge mode hooked up to my UniFi USG for a couple of weeks straight, and everything has been working like a charm. These are the firmware versions my RUTX09 has been running these past weeks:

Firmware: RUTX_R_00.02.01.1
Modem firmware: ? (internet tells me it could have been EG06ELAR03A05M4G, but that's too late to verify)

Today I noticed that I could update (1) my router's firmware, and (2) the firmware of the built-in modem. I decided to apply both updates, followed by a factory reset of the router to (3) make sure I didn't have any conflicting settings and to (4) make sure that my step-by-step guide to have the RUTX09 run in bridge mode together with my UniFi equipment still worked. Post upgrade, my RUTX09 is now running these firmware versions:

Firmware: RUTX_R_00.02.03.1
Modem firmware: EG06ELAR04A03M4G

Post the factory reset with these new versions installed, I completed the steps in the wizard - accepting all default settings / not changing a single thing. Once completed, I executed these four steps that got me to a working setup the last time (inspired by this post):

  1. Enabled the advanced (web) UI settings (in System > Administration)
  2. Re-ordered my network interfaces so that interface MOB1S1A1 was first in the list (in Network > Interfaces, or Network > WAN if you haven't enabled the advanced UI)
  3. Verified that failover was disabled for all interface (in Network > Interfaces, or Network > WAN if you haven't enabled the advanced UI)
  4. Switched the active mode for interface MOB1S1A1, from NAT to Bridge. In this view, I also made sure to correctly enter the MAC address of the USG router downstream

(note: the USG was connected to LAN1 on the RUTX09)

Then I waited for the router to apply the last configuration change. When it was done, I noticed that the previously solid 4G status light was now blinking (at ~1Hz), which seems to indicate that it's connected to 4G, but that no data session is established. In this mode, the USG doesn't seem to get the WAN IP that it got with the old firmware versions, nor is it able to perform any network (WAN) operations.

To debug the issue, I tried to restart the router - which didn't help. I then reset the router and followed the very above steps again, but instead of entering the MAC address of the USG I entered the MAC address of my MBP (which was connected to LAN1) to see if that would work better. It didn't - the same blinking 4G light was all I got.

If someone could advise what I could try next, I'd be very happy - I'd love to be able to put my router back in bridge mode.

by
Quick update: downgraded the firmware to firmware RUTX_R_00.02.01.1. Now the 4G LED doesn't flash any longer once the router is setup to be in bridge mode... but it still doesn't work :/

Looks like it's not passing on its WAN IP this time around either - trying to put my MBP as the unit at the end of the bridge, I notice that it doesn't get assigned an IP despite being set to use DHCP.

This makes me believe it's tied to the modem firmware version, somehow... Now if one could only easily downgrade the modem firmware version? Can't find those files anywhere :/

2 Answers

0 votes
by

Hello,

I successfully tested bridge mode on my RUTX device (same Firmware: RUTX_R_00.02.03.1; Modem firmware: EG06ELAR04A03M4G).

When Bridge mode is on, the 4G status light starts blinking (at ~ 1 Hz), this seems to indicate that it is connected to 4G, but no data session is established. This is because RUTX does not have Internet access and a public IP address in Bridge mode. All traffic is bridged.

Please, temporally disconnect USG and use only PC. Connect it to RUTX09 LAN port. Set your PC to obtain IP address automatically.

To test Bridge mode, follow these steps to configure:

•             Make sure that WAN failover is turned off and mobile is set as main WAN in the Network → WAN page.

•             Make sure that DHCP server is enabled on menu Network → LAN. If DHCP server is disabled on RUT, PC will not get IP address from ISP. You should set Static WAN IP address settings on PC to get internet connectivity or LAN IP address to access RUT Web UI.

•             Then in the Network → WAN → Mobile page select Mode: Bridge in the mobile configuration section. You will then see an additional configuration field for entering a MAC address appear. Enter your PC network interface MAC address, use colons to separate digit groups.

·                     Insert proper APN settings on menu Network → WAN → Mobile.

•             Save settings and reboot RUT device.

•             Wait about 5min., that RUT fully boots up in Bridge mode, then re-enable PC network interface or reboot your PC.

If issue still appears download troubleshoot file on menu System > Administration > Troubleshoot and send it to me via PM.

Regards.

by

After a troubleshooting with Simonas, it seems like macOS needs additional configuration to get bridge mode to work correctly using the steps you provided above. This is what we did:

  1. Factory reset of router
  2. Default settings in first-run wizard
  3. Enable bridge mode on the MOB1S1A1 interface
Additionally:
  • There was only one device connected to the RUTX09, hence we didn't enter a MAC address in the bridge settings
  • WAN failover was completely disabled
  • We did not re-arrange the interface order since the RUTX09 didn't have a (ethernet) WAN connection
The above works out of the box on a USG or a UDM Pro (not sure why I didn't get it to work the first time around), but it does NOT work out of the box when the receiving end of the bridge is a MacBook Pro (running macOS 10.15.4).
Since it's working for the intended use case on my end, I will consider this a non-issue. That said, people trying to do this with a MacBook Pro on the end of the bridge might not be very lucky.