subscribe to our Youtube


13340 questions

15854 answers


50340 members

+3 votes
1,588 views 16 comments

Apologies for having to repost this question. The failover is working on the RUT240, but NOT on the RUTX11.

RUTX11 Firmware 2.03.1.  The RUTX11 has an OpenVPN connection to a server. I've configured failover so that if the WAN (wired) primary connection is removed, the RUTX11 switches to the SIM1 connection (secondary), and the Event Reporting so that I get an SMS when failover occurs, or returns to the Wired WAN. I have configured 2 'check IPs' ( and, but only 1 success is needed for confirming that the link is up. I have noticed a couple of issues:

If the router has an active SIM connection before failover is configured, then it doesn't switch to the WAN after failover is configured, unless you disable the SIM connection. After the X11 changes to WAN, you can re-enable the SIM1, and the X11 stays on the WAN (as it should).

If you then remove the WAN connection, the X11 correctly switches to the mob1s1a1 connection (as it should), and I get an SMS saying 'Wan (wan) is down, switching to backup WAN'. However, if you then reconnect the WAN connection, I get an SMS saying 'Swtched to main WAN(wan)', but the X11 DOES NOT switch back to the primary WAN connection, (the data count on the SIM1 interface continues to climb, while the data count on the WAN connection doesn't change). Note that the System log shows the line "kern.emerg Switched to main WAN (wan)", but the data count on the interface shows indicates that this hasn't actually happened. The Wired WAN also shows as having an IP address, and being online, but the X11 doesn't appear to be using it.

If I then disable the Mobile interface, I get another SMS saying 'WAN (mob1s1a1 is down, no more backups to switch', and the X11 starts using the main WAN port (data starts increasing).

If I then re-enable the Mobile interface, the X11 keeps using the Main WAN, correctly.

As I said earlier, the RUT240 is working correctly, using on the Mobile interface, and on the Wired WAN interface

I have a RUTX09 with firmware 2.03.1 and have the same problem (it seems that way).

Today failover had to switch from WAN to mobile but after 1 minute it switched back to WAN. But suddenly after a few hours I received a SMS from the mobile operator that the whole internet bundle was used (12GB).
Teltonika devs, any thoughts? Can you replicate this?

2 Answers

0 votes

Thanks for the details. Can you also share the screenshots of your Interfaces and Failover configuration ?

Thanks for checking the problem.

The X11 had a WAN failure last night, and sent a message saying it was switching to mobile interface. About 20 minutes later it sent a message that it was returning to WAN, but when I checked this morning, it had stayed on the mobile interface and used 14GB of the SIM data.

Here are the config images:

+1 vote


I have followed your steps, but I haven't been able to recreate this issue. Because of that, I am suggesting you reinstall router firmware to the newest version (2.03.3) without using the “Keep all settings” option.

If the issue still persists after reinstall let me know and send me a router troubleshoot file via private message. You can download it from the router's WebUI, System → Administration → Troubleshoot.

The newest firmware can be downloaded from here:


Finally got to do some testing. Upgraded firmware, and defaulted modem. Did a basic setup WITHOUT the OVPN setup or running, and 'return to WAN after failover to mobile' seems to be working correctly. There is very little data flow without the OVPN running (I'm just viewing news site video), so tomorrow I'll redo the setup for the OVPN, and see if the 'failover return' keeps working with much higher data throughput over the VPN.
Further testing shows that the issue still exists, and is unrelated to the OVPN connection specifically.

I continued the previous test, but went to You Tube and started the Guns n Roses Sweet child of Mine video, to generate a more continuous stream. About 30 seconds in, I disconnected the WAN cable, and the X11 switched to the mobile connection. After another 30 seconds, I reconnected the WAN, and it correctly showed as online. However, the X11 continued using the mobile connection until the video stopped playing, then switched to the WAN connection as the You Tube timer ticked down to play the next video. The next video played over the WAN.

So it appears that as long as there is continuous data flow (such as video flowing) the X11 doesnt switch back to the WAN connection, even if it comes back online.

Once I work out how to PM, I'll send the troubleshoot file.
3 July 2020:

For the benefit of those searching for an answer, Teltonika have been able to recreate this issue, but do not yet have a fix for it. When one is available, I'll repost.
I can confirm the issue described above is still present in the latest firmware RUTX_R_00.02.04.1

In my case, there is also a continuous audio-video data flow from my 24/7 streaming security cameras.
This is a very important issue that needs to be resolved as soon as possible.

 Any comment from Teltonika support?
@sarunas, can we gat an update regarding this issue? Is it correct that Teltonika recreated the problem? If so, when can we expect a fix?
Short update regarding this issue:
Yes, we were able to recreate this issue, and we are hoping to release fix with the next firmware release. When the firmware with the fix will be released, or when I will have an exact release date, I will comment under this question.
Nice to hear the bug is going to be fixed. Can you please confirm that this bug is also going to be fixed in the RUTX09 firmware?
Yes, fix will be released for all RUTX series devices (including RUTX09)

Hi. First of all, i discovered recently Teltonika and it's a very powerful router! Good job!

I’ve this problem as well  

My Openvpn remains stick to the lte wan, even if the main wan comes up again, consuming all credit!

I had the same problem with pfsense and the only solution was to switch to opnsense 

I love the teltonika, but i’m bothered with this old issue  

Please add an option to kill all active sessions whenever a wan comes up again from a failover. Thanks.

Rutx11 with firmware RUTX_R_00.02.04.3

For those keeping an eye on this, I had a PM from Sarunas on 15 Sept saying that a firmware would be released in the 'the next 2 weeks at the latest' with a fix for this. Hopefully it will be out this week...

Hello. We have released new firmware, which includes the fix of this issue. You can download it from our Wiki page.

Confirmed fixed on my RUTX11 with firmware 2.05.1