7877 questions

9301 answers

14975 comments

12781 members

0 votes
278 views 2 comments
by

Hello,

Did you change the behaviour of the output state configuration in the last version (6.06.1) ?

Because one of my script doesn't work anymore.

My script set the relay output to the value BEFORE a reboot (I store the value in a file). The script is launched by the rc.local file once the system init finished.

And just after the execution of my script, a process start the modification of the relay, message in logread:

user.info Messaged Start from new event "Output" "Digital relay output off"

The modification should be done during the system init, not after OR the processing of rc.local start too early.

With the new firmware, I don't know WHEN I can launch my script. If you have a proposition, tell me it.

1 Answer

0 votes
by
Hello,

Could you tell me from which FW version you have upgraded to version 6.06.1?
Also, could you send me your script via private message so I could test it myself?
by
by
Hello,

As suggested by Jerome, I reinstalled the firmware without the setting.

Now there is no custom scripts.

To highlight the problem:

system > user scripts :

/usr/bin/logger "hello world"

exit 0

Reboot the RUT955

Analyse the logread:

The custom commands are executed once the system init finished (according to the wiki).

I see my message "Hello world" which simulates a script execution.

and, after 10 seconds, I see

... Digital relay output off

The custom scripts are started BEFORE the end of the init which could not be normal !

In my case a script put the digital relay on and, just after, the relay is off ...

Log at your disposal but you can easily check as me.

PS: Jerome knows the problem