5654 questions

6863 answers

11066 comments

6945 members

0 votes
909 views 3 comments
by

Hi All,

Seems other people have asked similar question but either none of the answer work or they've not published how the resolved it.

Have a RUT240 with a 4G Sim with a FIXED public IP.

  • Access to internet via the router is working,
  • Access to Router WEBUI working via the static IP
  • but no port forwarding (PF for short) works

Setup the PF via Firewall/Port Forwarding with these settings:

  • TCP, UDP
  • From any host in wan
  • To any router IP at port 8080
  • Forward to IP 192.168.1.20, port 80 in lan

3 Answers

+1 vote
by

Ok this has been resolved. - 

Was indeed the default gateway of the device I was trying to connect to was not set to the routers IP

(partly because the device had obscure name of 'router 1' instead of 'default gateway' )

still all's well that ends well.

Device network settings need to be set to:

IP Address: 192.168.1.? (same network as the router - or change the router IP to your device, either way they have to be on the same IP range)

Subnet: 255.255.255.0 (Both router and device must be same subnet)

Default Gateway: 192.168.1.1 (the IP address of the router **important**

Well thanks for everybody who responded help

Best answer
by
Hello again,

I'm glad to hear you managed on your own. Good luck using the router and otherwise!

Best regards,

DM
0 votes
by
Hello,

Regarding the issue you are having have you tried different port numbers? Also is your ISP provider allowing those ports? Because some instances the issue is on the ISP provider and sometimes even the firewall settings of the device you are trying to reach.

Hope it helps

Regards,
Jerome
by

Just to be clear, when you say ISP is that the internet services provider of the SIM in the router and not the internet provider of the network I'm access from?

I would imagine that all ports would be available on the sims network as its specifically designed for connecting to devices remotely but I have contacted them to check this anyway. (awaiting response).

No firewall (that i'm aware of) on the device I'm trying to access. and is accessible across the WIFI and LAN of the router.

I also tried changing the port of the routers webUI to the port I was try to use (8000) and it worked which suggest that the issue is not with a blocked port. but with port forwarding.

0 votes
by

Hi,

I did a quick test on my RUT240, forwarded port 8080 from WAN to another router's IP in LAN, port 80. It worked as expected for me, at least with the latest FW version. Perhaps there's something else in the topology that's causing the issue. Could you share some additional information?

  • What is the device using IP 192.168.1.20? Is it another router? If so, is it possible it's WAN & LAN IPs are in the same subnet? Is access to port 80 allowed from WAN on this device?
  • Can you download a Troubleshoot file from the System → Administration → Troubleshoot page and send it to me?
  • Even more helpful would be a tcpdump file. It contains packet capture information, but it is disabled by default because these files take up a lot of space. You can enable it in the same page (System → Administration → Troubleshoot):
  • After enabling it and configuring it like in the image, make a few attempts to test PF. Then download the tcpdump file and disable it.
The Troubleshoot and tcpdump files will contain sensitive information (in your case, at least your public IP address). So, if you wish please send it to me via private message. 

Good luck,
DM

by
The device is not a router, it’s a networked device, it’s connected on the LAN of the router. I’ve used one before on a 4g router with no issues.