4504 questions

5529 answers

8723 comments

5420 members

0 votes
211 views 4 comments
by
I have configured the DDNS service on the RUTX11 and from the DDNS account I can see the updates are regular.

I cannot access the router remotely. My SIM card is a standard one with public address, but the DDNS should do the magic, right?

RUTX11 is setup with custom IP source, which is the mobile1 network.

What other settings should I look at?

Thanks.

1 Answer

0 votes
by
System->Administration->Access Control->(remote ssh access, remote HTTPS access) and Network->Firewall->(general settings, traffic rules/Enable_ssh_wan/Enable_https_wan)

Regards,
by

Thanks for the response.

All the suggested settings are done, but still I cannot access RUTX11 remotely.

Thanks for any additional suggestions where to look into.
Marco

by
You can try a tcpdump on the mobile interface and see if something comes in:

tcpdump -i qmimux0 -n -v 'port 22' and do a ssh to your address/dns name.

You should see at least an incoming TCP SYN packet, if not that's a network issue.

If you have a SYN and nothing else you probably have something wrong at the firewall level.

If you have a SYN followed by a RST it can be either a firewall or dropbear issue.

If you have a SYN followed by SYN ACK and ACK the connexion is established.

Regards,
by
I can ssh the router locally using its LAN IP, while the ssh access to the DDNS address says it cannot be resolved by the ssh command.

Maybe we need to clear the basic setup before going ahead.

If I enter the DDNS address (https://myname.freeddns.org/) into the browser when I an connected locally, I can get access to the router. If I try to browse from another network, it fails.

Now, my public IP is like 151,82,166.24 while the address I can see from RUTX11 in the overview under the mobile connection is 10.34.248.120.

Should I look deeper into the Firewall/Routing setting?

Thanks.
by

"Should I look deeper into the Firewall/Routing setting?" : Not yet.

"the ssh access to the DDNS address says it cannot be resolved by the ssh command" : you have to solve that first.

Check on freeddns.org that your dns name and address are correct (the 151.x, not the 10.x), do a nslookup or dig of the dns name from another network and see if it returns the correct value.  If you want you can PM me your dns name I'll check it.