4219 questions

5218 answers

8038 comments

5224 members

0 votes
114 views 2 comments
by
Hello.

I want to start by saying that I am fairly new to ICT/IoT, couldn't find more info about this problem so here I go.

I'm using Teltonika RUT955/950 with 06.06.1 FW with my CentOS 8 OVPN-server. I have succesfully connected and routed the tunnel so there's no problem. One thing I found weird and really cannot find an explanation is that why tun0, tun1, tun2 and tun3 are connected to hotspot? Isn't tun0 etc. the default interface/device for ovpn tunnels? The problem occurs when I use my pre-made client config, not the GUI client setup (Names it differently, tun_c_client1 for example). Using the pre-made client config, with the tun0 interface my RUT955 thinks it is a hotspot connection and my/pre-configured (SSH/HTTP) traffic rules don't work the way I want them to. I can easily go around the problem using hotspot as the source, but that really isn't a fix.

Really appericiate any help or explanation!

2 Answers

0 votes
by

Hello,

Please try attached TEST firmware: https://community.teltonika-networks.com/?qa=blob&qa_blobid=15788540326782862337

Attached TEST Firmware release is for this particular issue.
Please check if this specific function works properly now.
Once we receive positive feedback from you – these changes will be included into next Master Firmware release version.
Note: without final confirmation that the issue has been resolved these changes will not be included into Master Firmware version, hence shall not be included from the Factory.

by
After very little testing;

It doesn't. I can now ping and connect with SSH through the tunnel, but my traffic rules configuration doesn't take effect. At all. For example it doesn't matter if I reject all ICMP requests, they just go through.

I'll test more and will get back to you on Monday.
by
Hello,

Is there any news after testing?

Also, recommend upgrading firmware without keep settings just for testing purpose.
0 votes
by
Hello again. I apologize deeply for the delay, been really busy with other projects and completely forgot about this one.

After little more testing it seems that my first answer was correct. I can connect through the tunnel and services like ssh work like I would like to, but the zone/traffic rules don't have any effect anymore.