subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
749 views 7 comments
by anonymous

Hi, i have huge problems with the 5ghz functionality. It doesn't work in any way. Once i'm changing the settings it is always on stopped state. After rebooting the RUTx11 it is in running state but i does not see the SSID with any device. ESSID is off, this setting is very unclear, it has to be off that the SSID is activated so it should be called "Disable ESSID" within the menu. Are there any known driver problems with at the current release?

demsg is showing some problems with the ath10k fw.

ath10k_ahb a800000.wifi: Direct firmware load for ath10k/QCA4019/                                                                            hw1.0/firmware-6.bin failed with error -2

[   37.176664] ath10k_ahb a800000.wifi: Falling back to user helper

[   37.947426] firmware ath10k!QCA4019!hw1.0!firmware-6.bin: firmware_loading_st                                                                            ore: map pages failed

[   37.947748] ath10k_ahb a800000.wifi: qca4019 hw1.0 target 0x01000000 chip_id                                                                             0x003b00ff sub 0000:0000

[   37.955388] ath10k_ahb a800000.wifi: kconfig debug 0 debugfs 1 tracing 0 dfs                                                                             1 testmode 1

[   37.968327] ath10k_ahb a800000.wifi: firmware ver 10.4-3.5.3-00057 api 5 feat                                                                            ures no-p2p,mfp,peer-flow-ctrl,btcoex-param,allows-mesh-bcast,no-ps crc32 6a15d6                                                                            4d

[   38.015670] ath10k_ahb a800000.wifi: board_file api 2 bmi_id 0:17 crc32 3ebd5                                                                            135

[   39.407558] ath10k_ahb a800000.wifi: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-ca                                                                            l-file max-sta 512 raw 0 hwcrypto 1

Overall i also can't pair the Router with my GalaxyS10. Both devices does not see each other. 

FW: RUTX_R_00.02.04.3

1 Answer

0 votes
by anonymous

Could you describe step by step how you tried to configure both Wi-Fi and Bluetooth connections so I could try to replicate the problem?
Best answer
by anonymous

Very simple: I just created an AccessPoint mode Wifi with WPA2-PSK nothing more as i did already with dozens of OpenWRT Routers. 

Here is the UCI output














And for the Bluetooth Paring i'm just searching devices to pair. I find a lot but both devices does not see each other. 

I'm scanning from the RUTX11 and i'm scanning from the GalaxyS10 Android 10 Kernel 4.14.113 (also with the Teltonika APP) but both devices are invisible for each other. I still need to check it with another Android device. But it is nothing special right? 

by anonymous
  • I just tried to create 5Ghz wireless AP myself and everything worked fine. One suggestion would be to restore your router factory default settings (System > Administration > General, press Restore button at the bottom of the page. If that does not help try to flash new firmware image from file without keeping settings. If that does not fix your problem with wireless AP, send me troubleshoot file via private message.
  • Talking about bluetooth, our routers cannot connect with mobile phones and vise versa so it is normal behaviour that your devices does not see each other.

by anonymous
Ok, i will try. But what about the Firmware Issue showed in dmesg?

And for Bluetooth it seems i misunderstood the usecase. I thought i can control the device with the teltonika FMBT App. What is the meaning for bluetooth what kind of usecase i can do with it?
by anonymous
by anonymous
Oh ok then i really misunderstood the bluetooth functionality :)

I will send you the troubleshooting file.
by anonymous

I am curious if resetting device to factory defaults or flashing new firmware helped out?

Also we found out that problem could be that you are using auto channel configuration.

To change that go to Network > Wireless and press Edit near 5GHz configuration:

Configure it as example below:

Let me know if that fixed you problem.

by anonymous
Hi, thanks a lot for your support. Reflashing the firmware did fix the issue, it is working now with AUTO Frequency, too.