4783 questions

5856 answers

9394 comments

5711 members

0 votes
270 views 8 comments
by

Good day,
I have TRB140, current firmware: TRB1_R_00.02.04.3

I have a user email defined
I have an event defined

enable: on
Event: reboot
Event type: all
Action: send email
Email user: myuser
Recipient's email address: myemail@mydomain.cz

Send test email: delivered without a problem.

If I restart TRB140, I will not receive any email.
Don't know where the problem is?

1 Answer

0 votes
by
Hey,

I just tested your case, and for me everything worked fine. Could you choose different event, for example instead of reboot try to recreate signal loss scenario and let me know if other options worked.

Regards.
by

Hi,
I tried, but nothing.
I also set up SSH successful authentication. Joined via PuTTy on SSH, but no notification.

Some idea?
The test email comes in without a problem.

Regards

by

I suggest, to try restore your router to factory default configuration: System > Administration and press Restore button at the bottom of the page. 

If problem still persist, send your troubleshoot file via private message to me. To download troubleshoot go to System > Administration > Troubleshoot and press Download button near Troubleshoot file.

by
I see you are using SMTP port 25 and no secure connection option. I suggest try to use port 465 and play with secure connection option. Let me know if that helps.
by
originally used smtp server: smtp.seznam.cz
port 465 secure, send failed
for my work only port 25.

here is log on other (my) smtp server:

my smtp server port 25: send failed
Aug 14 08:22:13 mail postfix/smtpd[9558]: connect from 89-24-46-196.nat.epc.tmcz.cz[89.24.46.196]
Aug 14 08:22:13 mail postfix/smtpd[9558]: lost connection after AUTH from 89-24-46-196.nat.epc.tmcz.cz[89.24.46.196]
Aug 14 08:22:13 mail postfix/smtpd[9558]: disconnect from 89-24-46-196.nat.epc.tmcz.cz[89.24.46.196]

my smtp server port 465: send failed
Aug 14 08:17:18 mail postfix/smtps/smtpd[7938]: connect from 89-24-46-196.nat.epc.tmcz.cz[89.24.46.196]
Aug 14 08:17:47 mail dovecot: auth: Warning: auth client 0 disconnected with 2 pending requests: EOF
Aug 14 08:17:50 mail postfix/smtps/smtpd[7938]: SSL_accept error from 89-24-46-196.nat.epc.tmcz.cz[89.24.46.196]: lost connection
Aug 14 08:17:50 mail postfix/smtps/smtpd[7938]: lost connection after CONNECT from 89-24-46-196.nat.epc.tmcz.cz[89.24.46.196]
Aug 14 08:17:50 mail postfix/smtps/smtpd[7938]: disconnect from 89-24-46-196.nat.epc.tmcz.cz[89.24.46.196]
Aug 14 08:17:53 mail dovecot: auth: Warning: auth client 0 disconnected with 1 pending requests: EOF
by

Another suggestion would be to check if you have enabled SMTP service in your email provider settings. Also try to check if sending emails work with gmail SMTP server (don't forget to enable SMTP service in google email settings) and configure email user as the example below:

by

If there was an error in the SMTP settings, then I assume I wouldn't even pass the test email, would I?


I set up smtp gmail, test mail will not come.

I send an email via ssh and it is delivered

Screen. https://filebin.net/rlw82pkofxlld8t2

by
While you are using secure connection please use 587 server port please.
by

I set port 587. The test email has been delivered.

I have established a new SSH connection to the root user. Email did not arrive