11324 questions

13494 answers

21161 comments

31592 members

+1 vote
951 views 9 comments
by
We are using multiple RUT955 (RUT955 T033C0, Batch No. 053) with the latest FW RUT9XX_R_00.06.06.1

We have trouble with the following issue related to the function "Restore Configuration" from the menue "System > Administrtation > Backup":

    - When a configuration file is selected, e.g. backup.tar.gz (which was created by the same device using the function "Backup Configuration" from the menue "System > Administrtation > Backup"), its name appears on the right side from the push button "Browse ...", this is the correct behaviour so far.

    - If then the push button "Upload archive" is clicked on, the name of the restoration file on the right side from the push button "Browse ..." disappears. In addition an error message is displayed in a red field on the top of the web browser page: "No file selected, please select a file". The restoration is not started.

FYI: I am using the Webserver GUI via Firefox web browser, version 75.0 (64-bit)

FYI2: Restoring from a Restoration Point is possible however.

1 Answer

0 votes
by

Hello,

We haven’t noticed any similar complaints and I can’t replicate this problem. I've been able to successfully restore the configuration from the same file several times using Firefox, Chrome or Explorer browsers.

·         Please, check that your backup file is undamaged and archived properly. Its format should be ...tar.gz. Try downloading a new backup file.

·         Use a different browser or clear the cache of the current browser. Also, you can try using a new Private browsing window.

·         Reset the RUT955 to its default settings and try to restore the configuration from the backup file.

Best regards.

by
Thank you very much for your response. It is confusing: I followed your instructions and additionally tried out multiple other scenarions, but could not restore the configuration using my own configuration backup created just minutes before. These are the scenarios which were used to force the device to restore configuration from file:

- CentOS 6, old web browsers Firefox ESR 10.0.3 and Seamonkey 2.3.1, normal and private brwosing mode in both browsers

- Linux Ubuntu 20.04, up-to-date Firefox web browser, version 75.0 (64-bit), normal and private brwosing mode

- Linux Mint 20, up-to-date Firefox web browser, version 77.0 (64-bit), normal and private brwosing mode

- Windows 10, the old Internet Explorer 11.805.17763.0 or the new Microsoft Edge 41.16299.1480.0, both: normal and InPrivate browsing modes in both browsers

- With all above scenarios we tried to upload the configuration backup *.tar.gz file with the originally created long file name or after renaming it to "backup.tar.gz" or just to "backup" - but this didn't make any difference

Meanwhile I am almost convinced that the issue is with the Firmware RUT9XX_R_00.06.06.1 . Most probably the file selection field does not pass the file name to the "Restore Configuration" script or does not pass it correctly.
by

Please, specify whether you tried to reset the RUT955 to its default settings and then restore the configuration from the backup file.

Alternatively, you can use SSH for configuration restore:

1.       upload configuration file ( e.g. backup.tar.gz) to the router. You can do this with WinSCP software:

File protocol: SCP

Host name: 192.168.1.1 (router IP address)

User name: root

Password:  <WebUI password>

Copy configuration file to /tmp directory

2.       Connect to RUT9xx by SSH. User: root Password: admin01 (or new WebUI password). Enter this command:

tar -C / -xvzf /tmp/backup.tar.gz

*backup.tar.gz is example file, you should write the name of your backup configuration file.

3.       To make packages work, two tiny commands are necessary to be executed after uploading the backup:

cd /etc/

./package_restore.sh

by

Dear SarunasKa

> Please, specify whether you tried to reset the RUT955 to its default settings and then restore the configuration from the backup file.

Originally I was trying to restore from a backup file without resetting to default. After you asked this question I tried this procedure with two kinds of reset: One trial after a reset to factory settings AND another trial after a rest to user default settings. The behavior of RUT955 did not change: the GUI did not recognize the backup file selected by me using the dialogue: "Restore from backup: Browse..." . As I wrote earlier: "Most probably the file selection field does not pass the file name to the "Restore Configuration" script or does not pass it correctly."

But the good news is: The restore from backup procedure via SSH does the job reliably and I am quite comfortable with that, thank you for this hint! I assume that other, less Linux experienced users might have issues. Therefore, if possible, please take up  my problem description above into your bug tracking database for a later fix.

by
Thank you for your contribution to the Teltonika forum and for bringing our attention to this.

A description of your issue is important to us and has been added to the bug tracking database.
by
I have exactly the same issue, when you select a previously made back up even from this specific Teltonika rut955 and then try to restore it you get the error "no file selected please select a file"

I have checked I am on identical firmware and as we have approx. 50 rut955's I have tried this on multiple devices and after the latest firmware you can not restore any backup configs made with .5 however if I use firmwares from older device firmwares to devices with identical firmware it still works fine.

Glad its not just me
by

Still no fixed firmware for this problem Teltonika?

Very disappointing considering I can not use any of my backups created from RUT9XX_R_00.06.07.5 without having to mess around with having to do it via SSH or re do every new Teltonika we buy manually!

If this is not fixed I think we will be changing provider back to Proroute as this issue does not seem to be getting fixed.

by

Backup files can be uploaded only from identical devices with identical or older firmware. Once a backup file is uploaded to a router, that router will have identical configuration as the router from which the backup file originated (was downloaded from).

The modified configuration file can be restored:

·        via Web UI on page System > Administration > Backup. 

https://wiki.teltonika-networks.com/view/RUT955_Administration#Backup

(Note: If you notice any issues, try using a different web browser or browse in private mode.)

·        via RMS platform Management > Devices > Configuration > Upload backup

https://wiki.teltonika-networks.com/view/RMS_Configuration_menu#Upload_backup

·        via CLI/SSH client command sysupgrade (here you can set any path to configuration file)

sysupgrade -v -r /tmp/backup-Teltonika-RUT955.tar.gz

If you connect USB stick to the RUT955, you can store or restore backup file from it.

To backup configuration:

root@Teltonika:~# sysupgrade -v -b /mnt/sda1/backup1.tar.gz

 

To restore configuration:

root@Teltonika:~# sysupgrade -v -r /mnt/sda1/backup1.tar.gz

by

Hi @SarunasKa and Teltonika team. I hit this problem this week, and will share detailed diags. Your suggested "solution" to use CLI command "sysupgrade -v -b /mnt/sda1/backup1.tar.gz" does not work, but instead returns an incompatibility error. Firstly, let me outline our key questions in order of importance:

  1. How do we find out the "product version" of an RUT955? The labels printed on the unit are identical apart from serial numbers. When we CLI and use commands "mnf_info -n", "mnf_info -v", "mnf_info -H", "mnf_info -b" we find identical values apart from the product names ("n") which are "RUT955003XXX" and "RUT955T03XXX". We've got 350+ units out there and NEED to know which units will work with our backup config and which will not.
  2. How many (incompatible) variants of the RUT955 are there, and where can we find this list published?
  3. When taking delivery a new RUT955 from a distributor, how would we know what variant we've received?
  4. Why can't Teltonika clearly add a version number on the case label?

 Now for the detailed diags to replicate the issue...

Unit A: "mnf_info -n" value RUT955003XXX | Serial number 1117993499 (batch 111)
Unit B: "mnf_info -n" value RUT955T03XXX | Serial number 1118095330 (batch 111)

Step 1: Download firmware RUT9_R_00.07.01.4 from https://wiki.teltonika-networks.com/view/RUT955_Firmware_Downloads and upload default firmware to each unit, choosing not to retain settings (revert to default config)

Step 2: Login into each unit (you will be forced to choose a new password, so choose same for each unit). Download the backup configs, saving file from unit A as "A" and unit B as "B".

Step 4: Attempt to restore config to unit A from the config file from unit B, and do likewise for unit B. You will be prevented with this error:
Popup error title: INVALID BACKUP
Popup error message: The selected backup file is not compatible with this device, please choose another file.

Step 5: Place file on USB and attempt for force restore using CLI command "sysupgrade -v -r /mnt/sda1/filename.tar.gz". You will be prevented with this error:
Ddd Mmm DD HH:MM:SS upgrade: Backup archive is not valid.
1

As you can appreciate, having 100s of units to be responsible for is only possible if we can reliably order a new replacement from a Teltonika distributor and quickly restore from a backup template; if we need to have multiple variants of that backup template then so be it, but we need to know HOW to identify each "RUT955" model quickly and we need to immediately know what variant we have received into stock when we get new orders arrive, in order to restore the correct backup file. Please urgently respond as I have 100s of these things to audit immediately. FYI: the 2 units above were literally ordered only 1 week apart.

With thanks,

Virgil.

UPDATE (since original post):

Contacting Teltonika - I tried ringing the number published on their website (+37037216110), but they do not answer and do not use voicemail.

I've tried to purchase model "RUT955T03" but I have wasted 10 days purchasing models listed on reputable distributors (inc. Senetic.de and WiFi-stock.com) as "RUT955T03" only to find that the model they send is "RUT955003"!!! This has happened 3 times, and I have to return for refund. Please, please, please....WHERE can I actually purchase an "RUT955T03" in Europe? I thank you for your most urgent reply as my project is now behind schedule and my client is frustrated, they are losing confidence in the Teltonika brand. 

As regards the advice from SarunasKa (@Teltonika): "For urgent questions, I recommend contacting Teltonika support directly via the VIP Helpdesk. If you don't have a account yet, contact your sales manager", I cannot find any way to access "VIP Helpdesk" and the only contact option at teltonika-networks.com is a simple "contact us" form (which I have completed). Can someone from Teltonika please confirm that the "RUT955T03" is no longer sold in Europe? Is it "end of life"?

by

Hello,

Thank you for detailed question.

Correct, product code information is no longer printed on device itself and is only available on the packaging boxThe product code shows not only its hardware but also its packaging. Therefore, it is printed only on the packaging box.

If you no longer have a packaging box, there are still multiple ways to determine device product code. That can be done by:

 - Powering on the device and connecting to its WebUI or SSH

 - Checking device serial number and searching it in excel files, which you receive with each shipment. I.e. after each shipment you should receive and excel file, indicating how many devices of each product code would be sent to you. In same exact file, all device serial numbers are listed. This file can help to determine exact device product code, if you only have its serial number.

As an alternative, an RMS platform could help you. It allows you to register your products from a csv file at once. Then you can then see all the product information:

 and upload the required backup file to all products with a few clicks:

Note: Backup files can be uploaded only from identical devices (same Product code) with identical or older firmware.

For urgent questions, I recommend contacting Teltonika support directly via the VIP Helpdesk. If you don't have a laccount yet, contact your sales manager.