8413 questions

9899 answers

15704 comments

14199 members

0 votes
653 views 14 comments
by
My RUT950 will often sit at status DISCONNECTED and I have to click to manually restart connection.  Why is it not continually trying to establish a connection?
by

Hello,

Could you please follow the following steps to upgrade  modem firmware to the latest. 

When upgrading, router must have internet access via e.g Wired WAN.

Go to CLI: Services>CLI

username:root

Password: same as you set to login the web ui

curl -s http://35.156.155.197/download/upgrade_ec25.sh --output /usr/sbin/upgrade_ec25.sh

chmod 755 /usr/sbin/upgrade_ec25.sh

/usr/sbin/upgrade_ec25.sh EC25EFAR02A08M4G 
For latest firmware version you can refer to the attached image you can find it in private msg. 
Based on modem model you will need to change last line accordingly to fw version to which you like to upgrade. You can see router's modem model in web ui of device Status>Device>Firmware version. Please consider 2 alphabets after EC25 to match with your modem's model . You could also consider date to know the latest modem fw for your modem. 
E.g. /usr/sbin/upgrade_ec25.sh EC25ECGAR06A07M1G
Hope it helps.
Thank you.
Regards,
Ahmed Rehan.

3 Answers

0 votes
by
Hello,

Regarding your issue may i know if you are using Auto APN functionality on your device? And may i know when does this issue happening is it when the device newly booted up? Kindly give me more details on the issue you are having :)

Thank you and have a nice day!

Regards,
Jerome
by
Hello Jerome

yes I send you the file. Both antenna are installed and the signal quality is ok.

To get the system working again I hade to go back to V00.06.05.3 and I added /etc/init.d/modem restart to the startup script.

The same seems to be working with 00.06.06.1  but then the Mobile connection status LED  keeps flashing green/red even if a connection is etablished.

Regads Daniel
by
Hello Daniel,

I didn't received any troubleshoot file from your side. Kindly send it via pm maybe? Make sure you are on the latest firmware and the device must be running for like 5-10mins before getting the troubleshoot file so that i can have the whole logs of the router.

Thank you and have a nice day!

Regards,
Jerome
by

Hello Daniel, 
Based on the troubleshoot file you sent the router is having very low signal quality. That is why there are disconnections encountered due to signal drops being experience by the router this may be caused by the signal reception from the cell towers of Swisscom. 

Here are the details that i found on the logs. 

'+QCSQ: "LTE",79,-106,166,-8'
QCSQ: "LTE",<lte_rssi>,<lte_rsrp>,<value3>,<value4> 

So base on the signal strength the device is getting it will encounter signal drops and an intermittent connectivity to the internet.

As reference you may refer to this link for more information: https://wiki.teltonika-networks.com/view/Mobile_Signal_Strength_Recommendations#4G_.28LTE.29

Hope it helps.

Regards,
Jerome
 

by
Hi Jerome

this is not the main issue. If i don't add the /etc/init.d/modem restart command to the startup script, I will newer get a connection. The system stays stucked with SIM1, no IMEI or other usefull information is shown on the Mobile Information page. The SIM switch should occure after some minutes, but nothing happens. I need to perform a manual ModemReset to get back in a working state.

Regards Daniel
by

Hello, 

It would be best to test the device where there is a good signal strength because on that results the RSRP value of -106 is really high and connection is close to none. Once you are able to find a spot which is having a better signal quality then we can check the issue much further.



Hope it helps.

Regards,
Jerome

Thank you and have a nice day!

Regards,
Jerome

0 votes
by

Thank you Ahmed. On my RUT950 i see this:

Modem
Model ME909u-521
FW version 12.636.11.01.00

I'm unsure what needs to change? e..g what would 

/usr/sbin/upgrade_ec25.sh EC25ECGAR06A07M1G

to match my model model ME909u-521?

Also, The 4G is my *only* internet connection, I do not have any wired WAN. However I do have SFTP/TFTP servers inside the LAN, is there an option to update from those?

by

 

Only wired WAN will work .

0 votes
by
Looking at that upgrade script, it will only work with Quectel devices; mine contains a Huawei.
by
Yes , you are right.