8298 questions

9759 answers

15542 comments

13863 members

0 votes
226 views 0 comments
by

I need to configure the TRM240 modem to work with a Raspbian system. I followed the procedure reported in the answer here, but the connection isn't working.

I attach some screenshots documenting the procedure and the commands that I issued.

First, look for connected modems:

Check the unique modem found:

Here, the Status section leaves me a little bit puzzled, but I try to go on.

I tried the following command using different options for ifname: cdc-wdm0, ttyUSB2 and ttyUSB3. They all end up to the same result.

Check the connections and try to take up modem:

Status of service NetworkManager:

Status of service ModemManager (there are warnings, but not errors):

System info:

1 Answer

0 votes
by

Hello,

Several configurations must be done. Please follow these steps:

First of all, you will have to disable Raspbian default network manager with command:

  1. systemctl stop networking.service
  2. systemctl disable networking.service - this will prevent default network manager from starting again automatically

And for some reasons default Raspbian dhcp service do not work properly with modems, so you will have to use udhcpc.

  1. install udhcpc sudo apt install udhcpc
  2. request ip address with udhcpc -i wwan0

With these two changes you will have to get internet connection via mobile interface.

Regards.