7012 questions

8392 answers

13629 comments

10306 members

+1 vote
534 views 18 comments
by

RUT950 router is losing connectivity to the ZeroTier network. The connectivity gets restored after the router is rebooted. To keep the network working the router requires a reboot every few hours. The most the router can operate properly is about 12 hours and then it requires a new reboot. Seems like a F/W issue. Is there an update?

by
Experiencing the same issue since the last firmware update on my 955.
by

Dear EB

I am having the same issues with Zeroteir disconnecting after some hours. Either rebooting the RUT950 or disabling/enabling the ZeroTeir-One in the router VPN menu fixes it?
1. As another member has already stated the available package version seems behind the curve in terms of release date? Yes I understand you need to have a complete verifiable build to ensure compatibility of code, but at the same time there seems to be a fundamental problem with this feature, reports of issues stem back to September last year, so is there a timeline for resolution based on an up to date version of Zeroteir client? One of the reasons I have chosen your product is for its intrinsic support of Zeroteir to bypass GCNAT - without this my project won't get that far. I would be very grateful if Teltonika could please provide expected rollout timeframe.
2. Even when Zeroteir is working the version number that is reported in the the Zeroteir Central dashboard is highlighted in red?
3. Below is a snip from my Zeroteir dashboard reporting the Teltonika Zerotier version as 1.1.14 when the package I have installed is 1.1.16 - why is this?
4. Is there anyway I can upgrade (at my own risk) the version of Zerotier later than 1.1.16?
5. I have sent you my troubleshooting file by PM.

Thanks for your time, Chris.


by
Also experiencing this issue constantly. I have been rebooting but will try the custom script solution.

I cannot justify buying any more routers if this is not resolved.

1 Answer

0 votes
by
Hi,

Have you noticed what exactly disrupts the connection? Has it happened more than one time and is there any way we could reproduce this issue?

Please come back with more details of your configuration and add screenshots of logs if you could, this way it will be easier to identify the issue.

EB.
by
Hello,

Any update on this.  As the above user, its the combination of cellular and ZeroTier that makes Teltonika the perfect solution for us.

I couldn't be certain but the loss of ZT connection is possibly affected by the carrier changing public IP?

Is there a way to restart the ZT service without rebooting the router?  Command line perhaps?

James
by
Back in October I was asked by a support team member to send in a troubleshooting file from the router.

Despite having chased it with him, I am still awaiting an answer !!!!!!

As a workaround I get the router to reboot if it cannot ping a machine on my ZT network.
by

Hi,

If instead of router reboot you want to reboot just the service, use /etc/init.d/zerotier restart command.

As for your concern @grumpazoid, probably the reason for that is this issue hardly reproducible and no one yet gave instructions to reproduce it. Right now, several clients are running ZeroTier VPN service and there were no issues reported to this day.

EB.

by
Thank you EB for that idea.

I have previously tried disabling and re-enabling the service manually and that did not work. Only a full reboot got things working again.
by
Same issue - Cannot contact by zerotier after period of time. Only solution is to reboot.