10948 questions

13055 answers

20356 comments

27891 members

+1 vote
441 views 2 comments
by

Hi, would it be possible to enable multi path in zeroTier over the UI on the RUTX12?

I tried to enabled it over the CLI by creating a local.conf in /var/lib/zerotier-one/, adding "multipathMode": 2,  but it's not picked up by restarting the service.

The file is copied to /var/lib/zerotier-one_NETWORKNAME, as setup in the /etc/init.d/zerotier:

      # link latest default config path to latest config path

        rm -f $CONFIG_PATH

        ln -s $path $CONFIG_PATH

But zerotier-cli -j status doesn't show it enabled.

If I run zerotier-one /var/lib/zerotier-one_NETWORKNAME, I can see it enabled, but no path is used....

The reason behind is that it would allow to use VPN bonding over 2 4G connections using a zeroTier server as default gateway

Thank you

by
Hi,

could someone from Teltonika answer, please:) Thank you.

1 Answer

+1 vote
by

Hello, you can add:

echo '{"settings": {"multipathMode": 2}}' >> $path/local.conf

in:

/etc/init.d/zerotier

at the end of start_instance function

I am attaching modified init.d script, you can find changes on line: 90

Zerotier_init

zerotier-cli -j status output after changes

{
 "address": "xxxxxxxxx",
 "clock": xxxxxxxxx,
 "config": {
  "physical": null,
  "settings": {
   "allowTcpFallbackRelay": false,
   "bind": null,
   "controllerDbPath": null,
   "multipathMode": 2,
   "portMappingEnabled": true,
   "primaryPort": 9993,
   "rabbitmq": null,
   "softwareUpdate": "disable",
   "softwareUpdateChannel": "release"
  }
 },
 "multipath": null,
 "online": true,
 "planetWorldId": xxxxxxxx,
 "planetWorldTimestamp": xxxxxxxxx,
 "publicIdentity": "xxxxxxxxxxxxx",
 "tcpFallbackActive": false,
 "version": "1.4.6",
 "versionBuild": 0,
 "versionMajor": 1,
 "versionMinor": 4,
 "versionRev": 6
}
 

by
Hi,

Is this supported on RUTX11?

Rory