subscribe to our Youtube


13247 questions

15731 answers


49881 members

0 votes
434 views 8 comments
I have purchased more than 10 Qty. TRB 142 GSM Modem. However, I am unable to send text SMS through this Modem. I tried though Hyper Terminal and our software application but I couldn't get success.

Steps I have followed:

1. Login into the web application and first downgrade firmware to get the option of RS232.

2. I have changed the control option - System > RS232 > Modem (and Save)

3. Open > Hyper terminal and select COM 1

After selecting COM 1, continuous error or auto printing is coming and I unable to type any AT commands. But anyway I want to send SMS through my application or through GSM modem.

It should not like every time I will have to save or change settings in the web portal.

So, please provide suitable solution.

1 Answer

0 votes


First of all, never downgrade your firmware, and please use the latest one: TRB1_R_00.02.05.1.

Configure your RS232 configuration as follows:

Open your Windows device manager and check which serial COM port number your TRB device got, in my scenario I got COM3:

Open that port and navigate Port Settings, configure it exactly the same as WebUI:

Open your SSH terminal, in my case I used PuTTY and configure connection parameters the same way:

You should successfully log in after these steps.


I have upgraded the firmware for TRB142 (ver: TRB1_R_00.02.05.1) and go through your steps but still I'm unable to get USB-Serial port in Device manager.

Please provide solution for the same.

I have TRB 145 modem, and I want to communicate it using serially, but can not apply full control for RS485, and the com port is not detected as you showed in the above solution. it is appearing as ADB serial cable.

Please replay ASAP.
If it appears as ADB serial cable, can you still configure settings in the device manager?
Yes, it is showing ADB in device manager but I am not able to configure com port and other settings
It may be an issue with the cable you are using or USB port in the computer. Try switching it up
I have tried in different three laptops
Just did a quick test with TRB145 and was able to see COM port appear in device manager, configured it, and successfully logged in to TRB using a serial connection. I suspect the issue lies in your RS485 cable
Hi, Could you please send me it? firmware TRB1450_R_00.01.06.1, My company has 15 TRB145 modems for that