FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14161 questions

16815 answers

27646 comments

54077 members

+2 votes
1,081 views 36 comments
by
(RUTX12 with RUTX_R_00.02.05.1) After I updated first the secondary Modem Firmware from the Server (Fota), the Update Button is blocked to update also the primary Modem.

Now, I see:

- Primary Modem = EG06ELAR04A03M4G

- Secondary Modem  = EG06ELAR04A04M4G

Please send me an Internet Download Link to File EG06ELAR04A04M4G for manually update the Primary Modem.
by

same error  (main 174 fail)

by

Info: The "/tmp folder"  is in Windows for downloading the 

C:\Users\homeuser\Downloads

by

Info: The "/tmp folder"  is in Windows for downloading the 

C:\Users\homeuser\Downloads

by
I experience the same bug. Updated one of the 2 modems from server, then can't update the other one, the update button being disabled when I choose that other modem (actually it's disabled for both modems, it makes sense for the updated one, but not for the not updated one).

RUTX12 running RUTX_R_00.02.05.1
Primary modem firmware version     EG06ELAR03A05M4G
Secondary modem firmware version     EG06ELAR04A04M4G

Is there an ETA on this bug fix?
Thanks and kind regards.

P.S.
Very nice product RUTX12. Thanks a lot for making it, for its UI and for its documentation.
by
Same issue here, is there a bug fix planned for this ?

Thanks
by
I also have the same issue. Is there a bug fix coming to the firmware?

1 Answer

+1 vote
by
Hi,

Here you go: https://kaunas.teltonika.lt:444/f/0b83d2356085413a9b94/?dl=1

Do you need instructions on how to update it?

EB.
by
Thanks. Yes help please! I try with Windows 10, Google Chrome and Explorer Edge but no File working. Every File not compatible.
by

Please download this: https://kaunas.teltonika.lt:444/f/530fea890087401f839d/?dl=1

Put it in your with WinSCP create folders /storage/modemfw and drop the file you've downloaded there.

Once you've done that, execute this in CLI:

/usr/bin/modem_upgrade /storage/modemfw/modem_upgrade.bin

EB.

by
It is not working.

The Teltonika CLI shows error message:

[email protected]:~# /usr/bin/modem_upgrade /storage/modemfw/modem_upgrade.bin                 

-ash: /usr/bin/modem_upgrade: not found

Windows: (my file is now in:    C:\Users\homeuser\Documents\storage\modemfw   )
by

Ok, sorry, the right usage would be:

First of all, output all available modems: 

ubus call gsmd get_modems

Then extract that modem .zip file you've downloaded to your /tmp folder, create a new folder called EG06ELAR04A04M4G and extract everything from zip into there.

Once you've done that use /usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G -p /dev/ttyUSBx (instead of x use the modem ttyusb output in ubus).

EB.

by

Sorry I don't understand. Teltonika-CLI shows ttyUSB2 and ttyUSB6. But now Error message (not found):



[email protected]:~# /usr/sbin/quectelFlasher
[000.000] QFirehose Version: LTE_QFirehose_Linux&Android_V1.0.3
[000.000] Builded: Feb 27 2020 21:25:59
[000.000] qfirehose.c main 171 fail
ro[email protected]:~# -f /tmp/EG06ELAR04A04M4G -p /dev/ttyUSB2
-ash: -f: not found
What now?
by

Hi,

/usr/sbin/quectelFlasher and everything from -f /tmp/..... must be in one line, its one whole command.

so just execute whole line in CLI:

/usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G -p /dev/ttyUSB2

by
OK Sorry. Thanks. Now a new error message:

---------------------------------                                                                  

   Teltonika RUTX series 2020                                                                       

 ---------------------------------                                                                  

[email protected]:~# /usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G -p /dev/ttyUSB2          

[000.000] QFirehose Version: LTE_QFirehose_Linux&Android_V1.0.3                                     

[000.000] Builded: Feb 27 2020 21:25:59                                                             

[000.000] qfirehose.c main 174 fail
by

Could you maybe try without -p /dev/ttyUSB2 ?

by

same error (main 174 fail)

by

Info: The "/tmp folder"  is in Windows for downloading the 

C:\Users\homeuser\Downloads

by
Could you explain what do you mean in Windows? Firmware folder must be in the routers /tmp folder
by

I put file into  "Windwos 10" folder. OK now. You mean i should use Windows-Program WinSCP?

I should log-in with FTP into my Router address 192.168.1.1  ?

by
Yes, you must put that folder I told you to create in the storage of the router.

EB.
by

I started WinSCP and gave in 192.168.1.1 Port 22 and Port 21

I can not connect to router with FTP or SFTP. I try with user "root" and "admin"   ? Strange?

by
You have to connect through SCP protocol.
by

OK thx. I connected now with WinSCP and let it run your command

/usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G -p /dev/ttyUSB2

After that Primary Modem  N/A

After that I reboot Router and I see same old version like bevore (EG06ELAR04A03M4G)
Here the flash protocol (first and last a little bit) of messages 

___________________________________

[email protected]:~# /usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G -p /dev/ttyUSB2          

[000.000] QFirehose Version: LTE_QFirehose_Linux&Android_V1.0.3                                     

[000.000] Builded: Feb 27 2020 21:25:59                                                             

[000.000] qusb_noblock_open port_name = /dev/ttyUSB2                                                

[000.001] P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0306                                      

[000.001] C: /dev/bus/usb/001/003 bNumInterfaces: 5                                                 

[000.001] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff                                            

[000.001] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms                                                         

[000.001] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms                                                         

[000.001] I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[000.001] I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

                                   

____________________...........      

____________________...........    

____________________...........                                                                                               

[089.181] poll_wait events=POLLIN msec=1000 timeout                                                 

[089.181] qusb_noblock_read cur=0, min_size=1                                                       

[089.181] switch to 'Emergency download mode'                                                       

[090.191] poll_wait events=POLLIN msec=1000 timeout                                                 

[090.191] qusb_noblock_read cur=0, min_size=1                                                       

[091.201] qfirehose.c main 203 fail                                                                 

[email protected]:~#                                                                                            

by
Could you do it again, but again without defining ttyUSB?

EB.
by


BusyBox v1.28.4 () built-in shell (ash)
____ _ ___ ____
| _ \ _ _| |_ / _ \/ ___|
| |_) | | | | __| | | \___ \
| _ <| |_| | |_| |_| |___) |
|_| \_\\__,_|\__|\___/|____/
---------------------------------
Teltonika RUTX series 2020
---------------------------------
[email protected]:~# /usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G
[000.000] QFirehose Version: LTE_QFirehose_Linux&Android_V1.0.3
[000.000] Builded: Feb 27 2020 21:25:59
[000.001] qfirehose.c main 174 fail
by
Please check if your modem firmware is still there, it might be that it got deleted in /tmp folder.

EB.
by

You are right. I reuploaded. Now:





[email protected]:~# /usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G
[000.000] QFirehose Version: LTE_QFirehose_Linux&Android_V1.0.3
[000.000] Builded: Feb 27 2020 21:25:59
[000.000] qusb_noblock_open port_name = /dev/ttyUSB0
[000.001] P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0306
[000.001] C: /dev/bus/usb/001/003 bNumInterfaces: 5
[000.001] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff
[000.001] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms
[000.001] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms
[000.001] I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.001] I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.001] I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.001] I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff
[001.003] poll_wait events=POLLIN msec=1000 timeout
[001.004] qusb_noblock_read cur=0, min_size=1
[001.004] switch to 'Emergency download mode'
[001.006] successful, wait module reboot
[001.029] qusb_noblock_read cur=0, min_size=1
[002.034] qusb_noblock_open port_name = /dev/ttyUSB0
[002.034] P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0306
_________________________........


_________________________........


_________________________........


[028.294] fail to claim interface 0, errno: 16 (Resource busy)
[029.303] qusb_noblock_open port_name = /dev/ttyUSB0
[029.304] P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0306
[029.304] C: /dev/bus/usb/001/003 bNumInterfaces: 5
[029.304] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff
[029.304] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms
[029.304] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms
[029.304] I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[029.304] I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[029.304] I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[029.304] I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff
[029.304] fail to claim interface 0, errno: 16 (Resource busy)
[030.313] qusb_noblock_open port_name = /dev/ttyUSB0
[030.314] P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0306
[030.314] C: /dev/bus/usb/001/003 bNumInterfaces: 5
[030.314] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff
[030.314] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms
[030.314] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms
[030.314] I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[030.314] I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[030.314] I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[030.314] I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff
[030.314] fail to claim interface 0, errno: 16 (Resource busy)
[031.323] qfirehose.c main 203 fail
by
Okay,

Please reset your router to factory defaults without keeping the settings, reupload the firmware again and turn off use of mobile connection - connect with wired wan and disable mobile interfaces.

After you've done that, run that command again and see if it flashes this time.

EB.
by
OK EB. I did it everything (I deactivated first the 2 Network Interfaces modem 1 and modem 2).
But after averything and reboot I think now the same. And same old Firmware

Remark: I downloaded a new ZIP File. After extract with 7-Zip I see a Warning "There are some data after the end of the payload data".  But I think is nothing, because if I extract with WinRar there is no Warnin message. So I used WinRar.

[email protected]:~# /usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G -p /dev/ttyUSB2          

[000.000] QFirehose Version: LTE_QFirehose_Linux&Android_V1.0.3                                     

[000.000] Builded: Feb 27 2020 21:25:59                                                             

[000.000] qusb_noblock_open port_name = /dev/ttyUSB2                                                

[000.001] P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0306                                      

[000.001] C: /dev/bus/usb/001/003 bNumInterfaces: 5                                                 

[000.001] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff                                            

[000.001] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms                                                         

[000.001] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms                                                         

[000.001] I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[000.001] I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[000.001] I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[000.001] I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff                                            

[000.742] qusb_noblock_read read=-1, errno: 11 (Resource temporarily unavailable)                   

[000.742] qusb_noblock_read cur=0, min_size=1                                                       

[000.742] switch to 'Emergency download mode'                                                       

[001.753] poll_wait events=POLLIN msec=1000 timeout                                                 

[001.753] qusb_noblock_read cur=0, min_size=1                                                       

[002.763] qusb_noblock_open port_name = /dev/ttyUSB2                                                

[002.764] P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0306                                      

[002.764] C: /dev/bus/usb/001/003 bNumInterfaces: 5                                                 

[002.764] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff                                            

[002.764] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms                                                         

[002.764] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms                                                         

[002.764] I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[002.764] I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[002.764] I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[002.764] I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff                                            

[003.773] poll_wait events=POLLIN msec=1000 timeout                                                 

[003.773] qusb_noblock_read cur=0, min_size=1                                                       

[003.773] switch to 'Emergency download mode'                                                       

[004.783] poll_wait events=POLLIN msec=1000 timeout  

________________________________.......               

________________________________.......

________________________________.......

[082.553] poll_wait events=POLLIN msec=1000 timeout                                                 

[082.553] qusb_noblock_read cur=0, min_size=1                                                       

[082.553] switch to 'Emergency download mode'                                                       

[083.563] poll_wait events=POLLIN msec=1000 timeout                                                 

[083.563] qusb_noblock_read cur=0, min_size=1                                                       

[084.573] qusb_noblock_open port_name = /dev/ttyUSB2                                                

[084.574] P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0306                                      

[084.574] C: /dev/bus/usb/001/003 bNumInterfaces: 5                                                 

[084.574] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff                                            

[084.574] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms                                                         

[084.574] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms                                                         

[084.574] I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[084.574] I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[084.574] I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[084.574] I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff                                            

[085.583] poll_wait events=POLLIN msec=1000 timeout                                                 

[085.583] qusb_noblock_read cur=0, min_size=1                                                       

[085.583] switch to 'Emergency download mode'                                                       

[086.593] poll_wait events=POLLIN msec=1000 timeout                                                 

[086.593] qusb_noblock_read cur=0, min_size=1                                                       

[087.603] qusb_noblock_open port_name = /dev/ttyUSB2                                                

[087.604] P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0306                                      

[087.604] C: /dev/bus/usb/001/003 bNumInterfaces: 5                                                 

[087.604] I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff                                            

[087.604] E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms                                                         

[087.604] E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms                                                         

[087.604] I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[087.604] I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[087.604] I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00                                            

[087.604] I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff                                            

[088.613] poll_wait events=POLLIN msec=1000 timeout                                                 

[088.613] qusb_noblock_read cur=0, min_size=1                                                       

[088.613] switch to 'Emergency download mode'                                                       

[089.623] poll_wait events=POLLIN msec=1000 timeout                                                 

[089.623] qusb_noblock_read cur=0, min_size=1                                                       

[090.633] qfirehose.c main 203 fail                                                                 

[email protected]:~#
by

I consulted with RnD and got this answer.

First of all execute these commands in your CLI:

echo 1 > /sys/class/gpio/modem_reset/value 

echo 1 > /sys/class/gpio/modem2_reset/value

both of them separately.

Then execute 

echo 0 > /sys/class/gpio/modem_reset/value

or 

echo 0 > /sys/class/gpio/modem2_reset/value

depending on what modem you want to flash.

Then execute this:

/usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G

and it should start flashing the modem.

After everything is done execute this:

echo 0 > /sys/class/gpio/modem_reset/value

or

echo 0 > /sys/class/gpio/modem2_reset/value

depending on what modem you didn't want to flash - to enable it back on again, as the commands you executed previously disabled not needed modem.

EB.

by
Sorry. I can't flash. I tryed with both modems.

BusyBox v1.28.4 () built-in shell (ash)                                                             

                                                                                                    

   ____        _    ___  ____                                                                       

  |  _ \ _   _| |_ / _ \/ ___|                                                                      

  | |_) | | | | __| | | \___ \                                                                      

  |  _ <| |_| | |_| |_| |___) |                                                                     

  |_| \_\\__,_|\__|\___/|____/                                                                      

                                                                                                    

 ---------------------------------                                                                  

   Teltonika RUTX series 2020                                                                       

 ---------------------------------                                                                  

[email protected]:~# echo 1 > /sys/class/gpio/modem_reset/value                                 

[email protected]:~# echo 1 > /sys/class/gpio/modem2_reset/value                                

[email protected]:~# echo 0 > /sys/class/gpio/modem_reset/value                                 

[email protected]:~# /usr/sbin/quectelFlasher -f /tmp/EG06ELAR04A04M4G                          

[000.000] QFirehose Version: LTE_QFirehose_Linux&Android_V1.0.3                                     

[000.000] Builded: Feb 27 2020 21:25:59                                                             

[000.000] qfirehose.c system_ready 127 fail                                                         

[000.000] qfirehose.c main 183 fail                                                                 

[email protected]:~# echo 0 > /sys/class/gpio/modem_reset/value                                 

[email protected]:~#
by
It's okay, I'm here until we solve this issue. Could you check if file still exists in the /tmp and zip is unpacked into the folder?
by

Yes it is. The ZIP Fils ist in:

/tmp/EG06ELAR04A04M4G

The ZIP File is packed

by
You need to extract it before using it. A recent comment by the user was incorrect.

EB.
by
OK. Now the update has passed good. Now I have the new Modem Firmware intalled. Both modems same. I see the unpacked zip files are not deleted on the router. I will delete later.

- Modem Interface activated successful

- Router Reboot successful

- Load Balancing activated and traffic works on both modems
 

Thank you very much :)           (now I will arrange to set up the Load Balancing togeather with VPN hide.me)
by
I have the same problem, I just want to update to a more recent firmware, tell me where you can download

EG06ELAR04A06M4G

EG06ELAR04A07M4G

EG06ELAR04A08M4G
by

Hello,

If you have firmware version 7.02 or above installed on your device, and access to another WAN source than mobile (WiFi or wired WAN), or at least to a mobile network from the other modem, you can use the instructions provided in this thread: https://community.teltonika-networks.com/52307/rutx09-sim1-reported-not-inserted-after-reboot-and-with-rutx

Keep in mind that modem ID and firmware versions in your case will differ from those provided.

Best regards,