11383 questions

13559 answers


31881 members

0 votes
1,195 views 3 comments

Im on FW RUT9XX_R_00.04.233 planning on upgrading to newest available FW..

(A month ago the WebGUI found new FW but now I get a "No update available", but that's alright as I'll just download it and do it manually).

However, I want to be prepared for if I have to reconfigure the whole device again after the FW-upgrade...

Last couple times I set this device up, back in mars-april 2018, I had to reconfigure it with every new fw-release I decided to try, and those were frequent back then.

But now I noticed the "Keep all settings" field, don't remember If that was available back then or if it simply didn't work as intended..

Best regards


1 Answer

0 votes

It should work as intended. The reason it might not have worked before is because of the new versioning system. There was an issue where if you upgraded from a firmware older that RUT9XX_R_00.04.75 to a newer one, settings weren't saved properly.

In any case, upgrade with keep settings from RUT9XX_R_00.04.233 to RUT9XX_R_00.05.03.3 should work without any issues.

Thank you Dziugas for answering in such short time.

Was about to try it out this evening as I also noticed the "Check for new FW" button resulted in the latest FW bin-file showing again. But after download is 100% completed, I only get "Firmware Upgrade - Verification Failed " .

I realize this might not be the best place to report a possible bug, but I thought I might as well let you know about it. 

Gonna proceed with a manual upgrade now..



I've looked into it and it seems that the file is unsuccessfully downloaded from RMS, that's why the verification fails. It may be due to the recent massive RMS upgrade. I've reported it as a bug so it should work again in the near future.

If you need a firmware image for manual upgrade, you can find it in Teltonika's Wiki. Specifically, for RUT9XX routers click here.


Update: they fixed it. Upgrades from server should now be working.