5276 questions

6429 answers

10373 comments

6439 members

+1 vote
130 views 5 comments
by 1 flag

Dear all,

I just bought a RUT240 and I just configured it to act as a 4G router. Everything is working but the wireless.

I am connected to the 4G network and sharing it through the ethernet cable, but any access to the wireless network is failing.

I tried all the possible options: 

  1. different passords
  2. different security methods (WPA2, WPA, OPEN)
  3. different wifi modes (b, g, g+n)

All the times I tried to connect to the wireless network it failed.

With WPA2 it continuously asks me for the password or says that the password is wrong.

If I just drop the security then it remains stuck and then moves to another network.

The clients I am using are OSX 10.14.6 and iOS 13.4.1.

The data of the router are:

Router model Teltonika RUT240 LTE
Firmware version RUT2XX_R_00.01.13
Kernel version 3.18.44
Bootloader version 3.2.2

Does anybody had similar issues?

I strongly suspect that my wifi module is broken.

Thank you in advance

m

by
Dear Teltonika support, any update with respect to this?

I now need to have two routers, a RUT240 for the connection to the mobile network and another one to provide a stable and performing wireless connection.

I am available to perform testing to investigaste the issue.

All the best

m

2 Answers

0 votes
by
I'm seeing the same behaviour with my RUT 240 (latest firmware, factory defaults), independent of the client used.

SSID is visible and offers a connection, yet a login never succeeds. Then, the AP even vanishes to come up again a short time later.

Is there any way to debug this problem?
Best answer
+1 vote
by
Short update!

I tried to use the router as a wireless client by connecting it to an existing wireless network, it worked.

Hence, the hardware seems working.

The problem now should be in the negotiation protocol with iOS and OSX, at present I don't have the possibility to test different OSes.

Has anybody experienced similar difficulties with Apple devices?

Thank you.
by
Could you try different devices like not apple products to see if that is the issue exactly with iOS?

EB.
by
I tried different options:

1. I just changed the password and my macbook was able to connect... Nevertheless it is working in an very erratic way. Sometimes is working some not. Android phones, at least the times I tried, are able to connect.

2. The wireless connection is definitely slow.

My current setup now is a RUT240 that connects through LTE, a GL.INET AR150 connected via ethernet to the WAN port and providing wireless access. This is working perfectly. If I move to the RUT240 wireless network the connections is incredibly slow.

I need some kind of support, I have to decide to return the device or not.

Thank you.
by
I am not getting the point... 2.4GHz channels are from 1 to 11... and 5GHz wifi is not available on RUT240.
by 2 flags
As to your question: If you set a country code like DE in advanced settings, channels 12 and 13 are available as well.

However this doesn't seem to have any impact - I have the very same problem: The router seems to work fine, but no connection to WiFi possible.

I have tried all available modes, both with world and DE country code, from desktops, notebooks and smartphones.

I run the latest available firmware and set everything back to factory defaults, except for the passwords and mobile settings. What can be the reason for such a behaviour?