4782 questions

5856 answers

9394 comments

5711 members

0 votes
58 views 1 comments
by

Hello,

I have a brand new RUT955 with last firmware.

If i read modbus registers, with modbus TCP/IP, with my PLC, it seems to work fine. But if I use modscan32, every time I connect it read values 1 time and after that it stops with a "connection terminated" error.

If I check the "keep persistent connection" flag, It works with both devices, but only for a minute. After that it has to be restarted.

How can it be solved?

1 Answer

0 votes
by

Hi Francesco.

Sorry for late response.

If I understood correctly, everything works correctly when reading registers from one device (PLC). Could you test with other testing software (like Modbus Pool) or do you have another device that supports Modbus? Notify me if the issue persists.

Best regards.

ago by

Hi Igor,

Modbus Poll keeps the connection alive and shows data, but every reading produces an error.
Funny thing: one reading error, one writing error, one reading error, one writing error, ... (even if I'm not writing).

Bonus fact: when selecting "keep connection alive" in the latest teltonika firmware, modbus32 stays alive. For around a minute :| then connection falls. PLC instead cannot communicate.

Bonus fact 2: with modbus tcp slave activated, after startup the RUT955 does not activate the 4G connection! It takes a IP from the mobile network but "no connection" is shown on the connections graph. Only after writing "1" in HR204 (mobile data ON) mobile data start to flow. This happens at every startup.