4783 questions

5856 answers

9394 comments

5711 members

0 votes
26 views 5 comments
ago by

I have been unable to restore a backup created by my RUT240 and dowloaded through safari locally with either of the 2 previous firmware versions. I get the error Incompatible backup file selected, please select another. A backup I created 6 moths ago does correctly restore though ? The only difference I can see is that the old backup has the file extension .gz where as the new backups don't have it when downloaded. I tried to use chrome to test a different browser but I just get a NET::ERR_CERT_INVALID when trying to connect to the web interface..... I am guessing this is a different problem as it has been present since i got the modem. 

ie backup-Teltonika-RUT240.com-2020-11-06.tar (missing the .gz that the original backup has) 

MacBook Pro OSX 10.15.7 Safari Version 14.0.1 (15610.2.11.51.10, 15610)

FW ver.: RUT2XX_R_00.01.13.1 failed on FW ver.: RUT2XX_R_00.01.13 as well 

1 Answer

0 votes
ago by
Hello,

Regarding the issue when you are generating backup both devices must be on the same firmware version and the same product code.
For more information you may refer to this link: https://wiki.teltonika-networks.com/view/RUT240_Administration#Backup
Also i think this is a similar issue with yours: https://community.teltonika-networks.com/2236/rut240-cannot-restore-its-own-backup

Hope it helps.

Regards,
Jerome
ago by
Thanks I only have one RUT240 this is happening on the same device ?
ago by

"Also i think this is a similar issue with yours: https://community.teltonika-networks.com/2236/rut240-cannot-restore-its-own-backup"

It is talking about the same issue but I am not doing anything to the file after downloading, and a file downloaded on a previous firmware version 6 months ago on the same computer and browser restores to the new firmware version on the same device....  

ago by

Hello, 

Could you check if the product codes of the RUT240 is the same and they have the same firmware installed? 

You can check the product code from the Status > Device Tab. 

Also FW ver.: RUT2XX_R_00.01.13.1 failed on FW ver.: RUT2XX_R_00.01.13 as well 

Make sure both devices is having the same firmware versions. 

Regards,
Jerome

ago by

Thanks I only have one RUT240. If I download a backup and try and restore it I get the above error ! 

Sorry that may of not been completely clear,

FW ver.: RUT2XX_R_00.01.13.1  If I download a backup with OSX 10.15.7 (19H15) with Safari Version 14.0.1 (15610.2.11.51.10, 15610) and try and restore it I get the above error ! 

FW ver.: RUT2XX_R_00.01.13   If I download a backup with OSX 10.15.7 (19H15) with Safari Version 14.0.1 (15610.2.11.51.10, 15610) and try and restore it I get the above error ! 

I updated the firmware to see if it was an issue with the previous version or also present in the new version

As I said above the only difference I can see is the file name for the old backup created 6 months ago looks like

backup-Teltonika-RUT240.com-2020-06-11.tar.gz

and a backup created today looks like this 

backup-Teltonika-RUT240.com-2020-11-22.tar

if I extract either the payload seems fine 

If I try and restore a backup from 6 months ago it restores .... on  FW ver.: RUT2XX_R_00.01.13.1 it restores.

Interestingly if I download the backup on iOS 14.1 and Safari I get a file that looks like and it will restore successfully

backup-Teltonika-RUT240.com-2020-11-22.tar.gz

If i add .gz to a backup it will not restore... 

So it seems there is an issues with downloads on Safari on OSX 10.15.7 

ago by

Hello, 

It seems to be the safari browser is not saving it properly could you try using different browser? The router will not recognize the backup file if it is not .tar.gz format 

Regards,

Jerome