10136 questions

12113 answers

18772 comments

20369 members

+1 vote
1,058 views 8 comments
by

I can't establish a Mobile WAN connection with the RUT240 (tried with two different SIM cards). 

Data connection state Disconnected
Sim card state Ready
Signal strength -67 dBm
Cell ID N/A
RSCP -67 dBm
Ec/Io -2 dBm
Operator N/A
Operator state Unregistered
Connection type 3G (WCDMA)
Connected band WCDMA 2100
Bytes received * 0 B (0 bytes)
Bytes sent * 20.6 KB (21069 bytes)

Only 3G seem available though in the Network Operators page OrangeB is broadcasting in 4G

Status Operator name Short name Numeric name Network access type Connect
Unknown BASE BASE 20620 2G/4G/3G
Unknown Orange B Orange B 20610 3G/2G/4G
Unknown Proximus Proximus 20601 2G/4G/3G

by
Did you just upgrade the router firmware or modem firmware?
by
Yes I have updated the firmware from 2019-06-07, 08:39:02 to 2020-11-19, 08:40:26 and tried the SIM on a RUTX12 installed in the same location without facing any issue. The mobile setup is in auto APN but the RUT240 refuses to connect.

Connection type

 PPPQMI

Mode NAT

 Passthrough and Bridge modes are disabled when multiwan is enabled

Auto APN

Connection will be established automatically

PIN number

XXXX

PUK code

YYYYYY

Dialing number

MTU

Service mode Automatic

Call utilities will not work as 4G-only service mode is on
by
SIM card was not properly activated on telco side. Router is working well. Thx

2 Answers

0 votes
by

Hello,

I would like to ask if you remember to which operator you were connected before the firmware upgrade? If yes, please select that operator by scanning the operator list manually and enter a custom APN. You can find your operator APN on their website or contact them directly to provide you with one. 

Regards.

by

Hi,

Yes the router always try by default to access same operator (Orange B ID: 20610). When I try to connect from the list of scanned operator I get the message "Can't register to selected operator". Same behavior if I set the APN manually

by
Our experience is that serveral APN setttings sometimes are broken when upgrading to latests firmware, at least on RUT955. Enter CLI, issue:

uci show | grep apn

and see what you find.

Also check the actual APN used by the router:

gsmctl -A "AT+CGDCONT?"

and see if that differs from what you expect to use.
by


root@Teltonika-RUT240:/www# uci show | grep apn
network.ppp.apn='mworld.be'
simcard.sim1.auto_apn='0'
simcard.sim1.force_apn='-1'
simcard.sim1.apn='mworld.be' # mworld.be is OK
root@Teltonika-RUT240:/www# gsmctl -A "AT+CGDCONT?"
+CGDCONT: 1,"IP","mworld.be","0.0.0.0",0,0,0,0 # mworld.be is OK
by
To make sure that it is latest FW issue, can you roll back to the previous FW version and check the same settings?
by
From your output from the uci commands above it seems not to be the same or related to the issue we have had on RUT955 where APN settings are out of sync with WebUI after firmware update.
0 votes
by
The issue is the IMEI. Probably your operator blocked the IMEI after the first 30 days because this is not register in your country. Here in Chile had the same problem. Work perfect the first 30 days, but after this impossible register and connect in the operator. I checked in the band system and my IMEI been blocked. Solution: When you purchase router register first and use the sim, or in case that is blocked, unlock the IMEI. Many websites do this.

Cheers