5747 questions

6966 answers

11234 comments

7060 members

0 votes
110 views 5 comments
by
Is there a way to configure TRB145 to automatically synchronize time/clock with browser time? Every time TRB145 switches-off, we have to manually press the "sync with browser" button in the setup wizard. This becomes a major issue in remote locations where continuous power supply is not available. We have to connect a PC with TRB145 through USB and go into the setup to make the above changes. Pls help.

Isn't it an issue with most users? Or is this an accepted issue with TRB145?

1 Answer

0 votes
by
Hi,

There is a reason why it's called "sync with browser", it need to be pressed while the browser in your computer is open, so it could gather data from it. Have you tried checking if NTP servers are working? What time do you get after restart?

EB.
by
Thanks EB for your response. We are ok to get the latest 4G operator time through SIM or through any NTP server as well. Preferred would be operator time. Pls suggest how the two options (operator and NTP) can be configured. Is there a recommended public NTP server that can be used?
by

Have tried changing the NTP settings in the TRB145 setup. But neither the openwrt NTP server nor the operator clock updates the time in TRB145 which creates a time lag for whatever time device was switched off. 

by
Try enabling Operator Station Synchronization, Force servers, and set Update interval to 100.

I tested this and it worked fine with my TRB device and the latest firmware version. You should see the correct time after couple of minutes.

EB.
by

This is not working for us. Done the same configuration as you suggested but time sync does not happen even after 30 min.

We are based in India. Should we replace openwrt servers with 0.in.pool.ntp.org, 1.in.pool.ntp.org and so on? Currently added 4 such servers along with openwrt ones. So total of 8 servers but still time not getting updated in 30 min. Or should we have just 4 local servers in India and remove openwrt servers? Pls suggest.

Also, changed "count of failed NTP requests" to 1. This will enable synchronization with operator station if NTP server sync fails even once. Hope this is ok.

by
You can definitely try that local 4 servers instead of OpenWRT. In this case, I can't really see why your time wouldn't correct itself. Have you tried maybe resetting the router? Or changing SIM to another operator and see how it behaves?

EB.