8899 questions

10555 answers

16569 comments

15924 members

0 votes
59 views 1 comments
by
<!--[if gte mso 9]> <![endif]--><!--[if gte mso 9]> Normal 0 21 false false false EN-US X-NONE X-NONE <![endif]--><!--[if gte mso 9]> <![endif]--><!--[if gte mso 10]> <![endif]-->

Hi,

So i have a problem with a number of RUT240 devices. The routers are running on a private 4G/LTE APN at a major service provider. I this APN they don’t have internet access, and LAN WAN addresses are manual mapped one to one and are fixed. So there is no DHCP involved. A fixed WAN ip address are assigned to each SIM card. And according to the network operator they do not assign neither netmask or default GW, as its not needed.
But it seems like the RUT240 are assigning itself both netmask and gateway. But they select this address on a random basis sometimes /31, /30 and /29.

This is causing me a major headache, as neighboring devises does not communicate as they probably think (depending on the random set netmask and GW) that they can reach the device locally.

How to I fix this problem, (without leaving 2 or 4 empty wan addresses between devices). Why is the router selecting random addresses, and is it possible to overwrite netmask and GW.

Best Regards

Eirik

1 Answer

0 votes
by

Hello,

please check if the RUT240 are upgraded to the latest firmware version (RUT240_R_00.01.13.1).

Download the troubleshoot file from your device (System > Administration > Troubleshoot) and send it to me via a private message.

Best regards,

Sarunas.

by
Hi,

I have found a temporary workaround that seem to work.

Edit the config. file for wwan0 setting it to static and manual netmask. 255.255.255.255. (not sure if this is a requirement or not)

Override the /sbin/ifconfig/wwan0 netmask to 255.255.255.255.  This also works after a reboot.

Have you fond a more permanent solution?