subscribe to our Youtube


13306 questions

15793 answers


50164 members

0 votes
251 views 8 comments
I have a RUT950 with a T-Mobile 4G sim card. The connection works great initially.

However, after 24h, the IP address is renewed. From that point on, the internet connection is lost. However, the Teltonikia interface still shows that mobile data is connected. I cannot ping any domains. I also SSH'ed into the router and tried ping from there ( and, but no reply at all.

Interestingly, the only thing that seems to be working, is doing a DNS request (using nslookup for example). This suggest that the data connection is fine. The firewall configuration is default. I also inspected the logs thoroughly but coundn't find anything suspicious.

I am having exactly the same issue on a RUT230 modem.  The only service that appears to be running is DNS !

The RUT230 is running FW RUT2_R_00.07.01.2

Custom APN is being used.

Have done some TCP traces using Wireshark - can see DNS is working and can see the 3-way TCP handshake working for other websites.

But any TLS communication is failing (after the initial 3-way handshake) is failing.

If I telnet to the IP address and TCP Port 443 - the actual TCP connection works  (i.e. agrees with the Wireshark that 3-way TCP Handshake is working).

The above to me would indicate that there is a connection to the internet via the RUT230 - but problem appears to be with any TLS communication ! (or at least that is what I am currently seeing).

Any ideas ?


1 Answer

+1 vote

Please check these options below:

1. Have you updated your RUT950 firmware to the latest available?

2. Have you tried restarting the modem after IP address is renewed? You can find it in Status > Network > Mobile and restart the modem from there.

3. If the restart of the modem helped, you can consider trying the auto-reboot option with modem reboot selected as an action on failed host ping.

4. Also, make sure you have APN selected or added as Custom, this way you will be sure that you're using the right profile, that your mobile operator provided you with.

Best answer

1. Yes, but it didn't make a difference.

2. Yes, that helps to get connection back.

3. I have considered this and it is our temporary work-around. However, this is not acceptable as long-term solution.

4. That is something I will try. We'll see in 24 hours if it makes a difference.
I don't believe it has to do with the APN setting. When I deliberately configure this wrong, the Mobile Data connection shows "Disconnected" and DNS is unreachable. This is different from the failure scenario. What else can it possibly be?
Are you using custom APN or you've selected it from the list?

Selected from the list, does that work differently under the hood then?
Yes, sometimes they do act differently and the selected APN might be not right. Could you check what APN did your operator give you or provide you with to use on their network and enter it in the custom field?

I have configured the APN using the custom field and the problem seems to be gone, thank you! I tested this two days in a row now.
Still going strong after a couple of days :)