8315 questions

9779 answers

15562 comments

13903 members

0 votes
544 views 1 comments
by

Hi,

Does the RUT240 support IPv6 on the mobile network?

I have a SIM card with a public static IPv6 address and I'm connection to a custom APN specific for static IPv6, but I'm getting assigned an IPv4 address. Is there a way to try and force IPv6 only?

I have enabled "IPv6 support" on menu System -> Administration

Connection type: QMI

Network provider: Elisa

Firmware version: RUT2XX_R_00.01.13.1

Kernel version: 3.18.44

Bootloader version: 3.2.2

2 Answers

0 votes
by

I think you need an Router from the x series. I have a rut240 and one x11. The x11 has the option you need under the following setting:

network -> interfaces -> mobile interfaceXY...

i cant find that option on the 240, looks like you need an update.

0 votes
by

I tried changing the firmware to a TEST FW for IPv6 support, then I get the option to select "Internet protocol version" under Mobile Configuration

It appears to work even tho it shows the Data connection as Disconnected in the interface.

I have an IPv6 address when I check https://www.whatismyip.com/, It's not the correct static IP but I have to check that with the network operator.

TEST FW downloaded from this thread: https://community.teltonika-networks.com/10674/rut240%26rut955-ipv6-mobile-disconnected

@Teltonika support, Is there a newer version available of the TEST FW with IPv6 support?

by

Hello,

Thank you for contacting .


On the RUT240 latest firmware version 01.13.1, you need to enable IPv6 support in the menu System > Administration as you already did.

Then you can adjust settings on the Web UI menu Network > WAN > Mobile (Edit).

By default DHCPv6 server is enabled. You can also make changes on the Network > LAN > General Setup page.

I have also attached some screen shots for your assistance. 

I hope it helps .


Have a good day.

Regards,

Ahmed