subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
527 views 4 comments


I use rutx10 to capture bluetooth probe data. Apparently, the router captures the data every 3 seconds. This means that if I configure the "data to server" with a 1 segment count, and send the data every 10 seconds, it turns out that I have between 3 and 4 mqtt messages each 10 seconds with a single data. You can imagine what happens when I set this parameter to 60 seconds or more. In the other hand, if I set "all" segments count, I get a single message every 10 seconds with 3 or 4 data. If in the bluetooth section I do not choose 'store data', I do not receive any message. For me it's a problem both to receive so many messages in a short time and to receive a single message with too much data. I’m sure some details are missing from me, so I would appreciate your help.

Thank you so much.

Best regads,


1 Answer

0 votes
by anonymous

Hello Raimon.

All supported parameters for data transfer to the server are described here. Hope this helps with the required configuration.

Best regards.

Hi again,

I am well acquainted with this document, and it seems to me that it does not answer the question I posed to you. Or I don’t get it right. I will try to raise the issue again.

First of all, comment that I use the mqtt protocol.

1st- I have a bluetooth temperature probe connected to the router.

2nd- The probe has an advetising period of 3 seconds. Therefore, for 60 seconds it sends 20 messages.

3rd - These messages are saved on the router, because if in the bluetooth section I do not check the save box, no data is sent to the server.

>>> Am I saying that right, so far? And a question I didn’t ask: are the data stored in memory? (1st question).

4rt- In the data to server section I decide that I want to send the data in object format and therefore I have to mark that I only want one segment.

5th - I set the sending period to 60 seconds.

6th - Because the probe sends new data every 3 seconds and the router saves all of them, between each sending, 20 readings are accumulated.

7th - Because I want to receive the data in object format and because with this format only 1 segment can be marked, the end result is that I receive in an instant and every 60 seconds, 20 mqtt messages.

8th - If instead of setting 1 segment I accepted all of them, every 60 seconds I would receive 1 single message with an array of 20 data.

9th - Neither of the above two situations satisfies me. So:

10th - Is it possible to only send the last reading of the probe? Or from each of the various probes I may have? This is the second question.

Thank you so much.

Best regards,


by anonymous
Thanks for your detailed description. I will consult with HQ and then give you an answer.
by anonymous
Q: Are the data stored in memory?

A: Yes, bluetooth sensor data store in router's internal memory in /tmp/.blesemd_db file

Q: Is it possible to only send the last reading of the sensor? Or from each of the various sensors I may have?

A: There is option to set emit period to 10s in bluetooth sensors and set 10s period in data to server feature, that way router will only send one string of sensor's data to server. If sending period will be set to 60s, then router will send 6 strings of sensor's data. Unfortunately, currently there's no option to select which of stored data will be send and router will send all collected data.

Best regards.
by anonymous
Hi, on my RUTX11 this file is called "blesemd_db" so without a preceding period symbol.

The file is 16k and has today's timestamp so I guess data is being written. But when I FTP the file to my Windows laptop and query it using the SQLite browser I have zero records. It's empty. When I download the file mdcollectd.db and browse it I do see data.

Do I first need to flush the blesemd data to the file, or something like that?

UPDATE Jan'23 : Firmware 7.03 fixed this problem

I have 3 blue pucks with "store data" enabled.

Thanks, Simon