11341 questions

13514 answers

21177 comments

31665 members

0 votes
294 views 11 comments
by

Hello, I have a RUT230 without phisical access.

I have upgraded the firmware through local web interface (a RaspPi with remote access on the connection of the RUT230), with tick on "keep all settings". new firmware is RUT2XX_R_00.01.13.2

Now the connection does not reestablish, even after a power supply cycle of the whole system.

The SMS utilities are working. With "status" the reply is

Router name - RUT230; WAN IP - ; Data Connection state - disconnected; 

Connection type - HSDPA+HSUPA; Signal Strength - -57 dBm; New FW available - No;

Is there a way to re-connect the data connection with sms utilities?

Thank you,

Carlo
 

1 Answer

0 votes
by

Hi,

It could be that somehow APN might have changed or isn't parsed as it should.

What I would suggest is reset the device without keeping the settings with SMS utility text restore.

This way you will put your device into reset procedure and once it's done we can be sure there's nothing else that could be wrong with the device, so only APN set-up is left.

Then what we should do is send uci commands through sms utility. Please let me know how it goes.

<adminPassword> uci set simcard.sim1.auto_apn='0'

<adminPassword> uci set simcard.sim1.force_apn='-1'

<adminPassword> uci set simcard.sim1.apn='bangapro'

<adminPassword> uci commit

<adminPassword> luci-reload

EB.

Best answer
by

Thank you! Can you please clarify few doubts:


- 'bangapro' shoud be replaced with actual apn, or this is a reserved keyword?

- with "restore" will the LAN IP of the router reset to 192.168.1.1? (we are working with range 192.168.0.1 and I'm afraid we would loose the connection). Maybe there is a uci command to change LAN IP?

- I'm quite confident there is no pin number on the sim (disabled before inserting), but if we have to introduce it, there is a uci command?

-  there is a full list of config file that can access with uci?
 

Thank you,
best regards!

by

We have access to another RUT230 with same SIM-operator.
 

Here is a screenshot to see APN configuration. is the apn the exact text between brackets?

by

1. bangapro is the local APN we use with our operator, instead of it you should use your own APN from your operator.

2. Yes, it will reset to default LAN, to change it with uci:

uci set network.lan.ipaddr='192.168.0.1'

uci commit

luci-reload

3. uci for PIN:

simcard.@sim[0].pincode='1234'

4. Full config might wary from devices and current settings set, so the best way to know what you can set-up in your device is to open up full uci list by yourself:

uci show

And you can use pipe to search for something through the list:

uci show | grep keyword

Regarding your question about APN in the dropdown menu - yes, these are APNs available to you, but sometimes APN you need isn't in the list so you have to fill it by yourself, just use "--custom--" selection and write your APN there.

EB.

by
Thank you!

I'm going to test everything this morning.

One last thing, the router admin password also will be reset with factory setting "restore" command? that was "admin01" [edited] ?
by
Yes. You're correct.
by
Thank you for the availability!
for now it's not working... here is the process I went through, all via SMS:

> oldpassword restore

> oldpassword status

[no reply]

> admin01 status

[the password-change confirms that the restore was successful]

Router name - RUT230; WAN IP - ; Data Connection state - disconnected; Connection type - HSDPA+HSUPA; Signal Strength - -57 dBm; New FW available - No;

> admin01 uci set simcard.sim1.auto_apn='0'

Replaced existing value simcard.sim1.auto_apn='0'

> admin01 uci set simcard.sim1.force_apn='-1'

Created new option simcard.sim1.force_apn='-1'

> admin01 uci set simcard.sim1.apn='airtelwap.es'

Created new option simcard.sim1.apn='airtelwap.es'

> admin01 uci set network.lan.ipaddr='192.168.0.1'

Replaced existing value network.lan.ipaddr='192.168.0.1'

> admin01 uci commit

[no reply]

> admin01 luci-reload

[no reply]

..wait 5 minutes

> admin01 status

Router name - RUT230; WAN IP - ; Data Connection state - disconnected; Connection type - HSDPA+HSUPA; Signal Strength - -57 dBm; New FW available - No;

I didnt get confirmation of "uci commit", "uci commit simcard", and "luci-reload". is it ok?

in the working RUT230, I dont see any "luci-reload" in the list of sms commands, is it "admin01 uci luci-reload" maybe?

I tryied reboot, and wait 5 min, but no success. I will now try other apn in the list of the other router (see comment above).

May be worth to try auto-apn? the first time it was successful without manually inserting it.

for additional debug:

> admin01 uci show simcard

simcard.sim1.dialnumber=*99#

simcard.sim1.reconnect=1

simcard.sim1.ltebandval=1a0000800d5

simcard.sim1.bandval=ffff

simcard.sim1.ifname=wwan0

simcard.sim1.proto=qmi2

simcard.sim1.auth_mode=none

simcard.sim1.service=auto

simcard.sim1.pdptype=1

simcard.sim1.auto_apn='0'

simcard.sim1.force_apn='-1'

simcard.sim1.apn='airtelwap.es'

simcard.sim1.pincode='6612'

simcard.sim2.dialnumber=*99#

simcard.sim2.reconnect=1

simcard.sim2.auto_apn=1

simcard.sim2.ifname=wwan0

simcard.sim2.proto=qmi2

simcard.sim2.auth_mode=none

simcard.sim2.service=auto

simcard.sim2.pdptype=1

simcard.simcard.default=sim1
by
Hi,

It's okay that uci commit and luci-reload didn't respond to you, it's normal. And if you had luck without APN, just with AUTO, you can try auto setting then. Just to make sure everything is clean try restoring again, and then just leave it to load normally.

SMS utility status should give you the state of your mobile connection.

EB.
by
No luck with clean restore and leave it with auto-apn=1.

I checked "uci show simcard" for two RUT230 that are working and there are these additional settings:

simcard.ppp.demand=10; simcard.sim1.method=nat;simcard.sim1.force_apn=137;simcard.sim1.mtu=1500

I added them, but still no luck.

maybe is not set to go to mobile? can we set to connect straight away with mobile instead of first test wired WAN, if it is so by default?
by

I did an additional reboot  and it seem it WORKED!!!

I will go to change local ip and check everything is good, but for now seem ok (SMS status -> connected)

The setting that made the difference seem to be "force_apn=137", what does it mean for information?


Thank you very much and congratulation, the SMS utility is a robust and very powerful tool!

Carlo

by
Thank you for your appraisal :)

force_apn=137 means that function selects 137th APN from the database.

And glad that you sorted out the issue yourself!

EB.
by

I confirm that have now the raspberry online! You helped a lot pointing in the right direction, much appreciated!


 

fyi,

i was finally issuing the commands with the value without '  '  

I dont know if it makes any difference, but I notice on the second router respnses were

simcard.sim1.auto_apn=1

instead of

simcard.sim1.auto_apn='1'   

all good from my side. Best regards!