10933 questions

13039 answers

20331 comments

27463 members

0 votes
230 views 4 comments
by

Hi!

I'm trying to setup the following configuration and I made it only half way.

Server (Ubuntu) pptp Server with Static Public IP.

192.168.1.2 (server) - Public IP Advantech (port forward) so that Public 31.0.xx.xxx goes directly to the server.

SSH works, connection is present.

On the other side I have TRB140 configured, logging, tuneling is working. It is set up for 192.168.2.1.

I can see the server, it's LAN and everything is working. But what I need is LAN after the TRB.

So everything on 192.168.2.yyy subnet.

Or even only have unit that is connected to the TRB forwarded to the pptp so that when I access on the server 192.168.1.101 (as this is the first pptp device I could see this device.

I think that this is very simple thing to setup, but I fail.

Could you advise how to overcome it?

I'm not a network expert, this is needed to have remote access to our devices, magic happens once we could have it connected.

I await your feedback.

1 Answer

0 votes
by

Hello Jan,

You need to add a static route on the side of your ubuntu server, detailed information can be found here.

Best regards.

by

Thanks,

I appreciate help, but it has not solved the case.

I'm still unable to make it propper way.

Do you by any chance have any sort of example, or could help me with propper wouting based on given values?

I other words how to set route so I could talk from device in Ubuntu subnet talk to device behing TRB.

I do appreciate your help.

Jan

by
  1. Make sure that your PPTP connection between Ubuntu server and TRB is established. I suggest you read this article to check all steps to establish a connection.
  2. Then you need to create a static route on your TRB device. Example: 
  3. Make sure that the route is created, go to the menu Status->Routes. You can see something similar:
  4. You can check LAN access behind your Ubuntu server, using ping command from CLI trb140.  Example: ping 192.168.1.2. If you don't have access to devices on the 192.168.1.0 network, you need to add static route to your Ubuntu server. Additional information: 

https://www.networkinghowtos.com/howto/adding-persistent-static-routes-on-ubuntu-18-04-and-higher-using-netplan/

https://www.ccnablog.com/static-routing/

Best regards.

by
Hey Again,

Indeed you helped me a lot.

Now I'm able to ping the device, but still unable to connect. It still doesn't show when I scan my subnet. Therfore can not have a communication with device.

What I'd need to have it listed like other devices i. e. every device in pptp shows as 192.168.1.101... 102 up to 130 (that is setup).

So is there a chance to have device behing router visible in the subnet?

Jan
by

Hi Jan

Send me troubleshoot file via private messages, you can find it on the menu: System->Administration->Troubleshoot

https://wiki.teltonika-networks.com/view/TRB140_Administration#Troubleshoot_2

I just want to make sure your settings are correct.

Best regards.