8413 questions

9899 answers

15704 comments

14199 members

0 votes
2,413 views 8 comments
by
Hi,

I have problems changing the configuration with "set". The UCI commands "get" and "show" works.

admin01 uci set network.lan.ipaddr=10.77.20.1

admin01 uci commit network

When I run the command "admin01 uci get network.lan.ipaddr" I get as an answer the old IP-address (192.168.1.1).

Am I missing something?

//klaus

1 Answer

0 votes
by

Hello,

Once you send "admin01 uci set network.lan.ipaddr=10.77.20.1" SMS command to the router, router should respond with "Replaced existing value network.lan.ipaddr=10.77.20.1" SMS message.

Do you receive such SMS messages from the router? If no, then your router does not accept/recognize the SMS command.

To begin with, check for any typing errors, which might occurred by accident (e.g. incorrect password, missing space between password/command/parameter etc).

If SMS command is indeed correct, would you be able to send one more "uci set" command to the router, then download troubleshoot package from the router and upload it here? (Troubleshoot package can be downloaded from "System -> Administration -> Troubleshoot" menu)

Note: Troubleshoot package contains router's configuration information and current router's logs. All passwords and certificate information is hidden automatically (not included in troubleshoot package). Nonetheless, it is recommended to remove any other information (e.g. phone numbers) that you might not want to share publicly.

by

Yes, I receive the reply  "Replaced existing value network.lan.ipaddr=10.77.20.1" from the router. After that I send the command admin01 uci commit network, but nothing happens. The ip-address is the old one when I send the command admin01 uci get network.lan.ipaddr.

by

Just checked this scenario with RUT2 and RUT9 routers, using latest firmware versions (RUT2XX_R_00.01.04.2 and RUT9XX_R_00.05.04) and was not able to reproduce the issue: UCI commands working without any issue, value changed, router correctly responded to "uci get" command with new value.

Do you have a possibility to try using latest router's firmware version? They can be downloaded from here: RUT2 FW , RUT9 FW.

If not, try to repeat same process (send same SMS commands to the router), then download troubleshoot package from the router and upload it here (Troubleshoot package can be downloaded from "System -> Administration -> Troubleshoot" menu).

by
Hi,

I have a RUT950 router with the version 00.05.03.4. The problems started when I updated the firmware to the version 00.05.03.4. After I installed the new version  ( 00.05.03.4) I cannot any longer access the router, because I cannot change the APN with the cellular SMS command. Also the reboot command isn't working in the version 00.05.03.4   UCI SMS API is now my only possibility is to remotely configure the router, so that I can over the internet access the router's web ui and finish the configuration.

//klaus

  .
by

Hello,

Certain mobile operators allow SIM cards to connect to the network even when no APN is configured on the device. If SIM card in your router can connect to the internet without APN (i.e. if in your case APN is needed not get "internet access", but to just get "Public IP" from operator), then you can still reach your router remotely. You can find out if router has internet connection by sending "admin01 status" SMS message to the router and checking if router responds with any WAN IP address and if "Connection state - connected" text is visible.

  •  If this is the case, then you could use RMS to access your router. Steps would be:
    • Send "admin01 monitoring_status" SMS message to the router. If router responds "Monitoring - disabled", send "admin01 monitoringon" SMS message to the router.
    • Once monitoring is enabled, open RMS webpage and create an account if you do not have one yet: https://rms.teltonika.lt/
    • Once logged in, select "Device -> Add device" and enter your router's Serial number / LAN MAC address, which you have received from the router with response to "monitoring_status" command.
    • Wait several minutes until router will connect to your RMS account. Once device is connected, you can press "Web UI" button to connect to router's WebUI directly:

  • However, if SIM card in your router cannot establish mobile data connection without APN, then, unfortunately, there is no possibility to configure/access this router remotely. In such case, physical connection to the router is necessary.
by
Hi,

Mobile data is on, but the monitoringon command doesn’t work either.

I give up.

Thank you very much for your help!
by

Hello,

I have checked "admin01 monitoringon" SMS command with RUT9 router and "RUT9XX_R_00.05.03.4" firmware version before providing last answer and it was working for me without any issue. I have also double checked it today.

Does your router continue to respond "Monitoring - disable" message to  "admin01 monitoring_status" SMS command even after "admin01 monitoringon" SMS command was sent to the router? Could you try to send "admin01 monitoringon" SMS command to the router once again?

by
Yes, I continue receiving the "Monitoring - disabled" as an reply. It seems there is something seriously wrong with the router, because I cannot change any settings via SMS or UCI SMS API. When I retrieve information i.e. with the status and monitoring_status SMS command everything works. Also the UCI uci get command works. The SMS command reboot doesn't work either.

//klaus
by

Hello,

Unfortunately, in such case router must be configured locally (by connecting computer directly to the router).

We are sorry for the inconveniences you have encountered with this firmware version.