6129 questions

7410 answers

11978 comments

7759 members

0 votes
48 views 6 comments
by
Hello,

I need to use DHCP options 43,66,160 on a TELTONIKA RUTX11, tried the following syntaxes :

43,http://myprovserver.fr

43,'http://myprovserver.fr'

43,"http://myprovserver.fr"

Putting the IP address does work but as the prov server IP might change, I need to input domain string.

Any solutions for this ? I am currently running RUTX11 on Firmware :

RUTX_R_00.02.05.2

1 Answer

0 votes
by
Hi,

Please update to the latest firmware version there is, I just checked and on 02.06 you can input strings into DHCP options field.

EB.
by

Thank you for the quick answer smiley

by
I updated to 2.06 but can not get it to take strings into account either.
Always rejected with "invalid values"
by
Sorry, just checked and it didn't save properly because it doesn't accept it. Will report this to RnD as a suggestion.

Thank you for your feedback.

EB.
by

Ok, I will watch out for any updates on this topic, thank you yes

by

By the way, wouldn't it work for you if you would insert all possible IP addresses? Like:

43,84.x.x.x,85.x.x.x

EB.

by

RnD confirmed that they will likely add this in the future development. For now, you should be able to add string address with help of CLI.

1.Go to CLI, log-in.

2. Type uci add_list dhcp.lan.dhcp_option="3,yourURLaddress"

3. Type uci commit

4. Type luci-reload

5. Type /etc/init.d/dnsmasq restart

EB.