6765 questions

8141 answers

13243 comments

9526 members

0 votes
84 views 2 comments
by
Hello,

I have the problem that my router doesn't update the custom DDNS service.

Router: RUT950
FW: RUT95XX_R_00.06.07.5
Connected over LTE (Europe, Austria, Provider "drei") -> It works!

My (activated) setting:
Enable: ON
Use HTTP Secure: tried ON and OFF
Status: N/A
Service: -- custom --
Custom update URL: https://dynamicdns.key-systems.net/update.php?hostname=<myHostName>&password=<myPW>&ip=auto
Lookup host: <myHostName>
Hostname: <myHostName>
User name: <empty> (not needed)
Password: <empty> (not needed)
IP address source: Custom
Network: WAN
IP renew interval: 10 (Minutes)
Force IP renew 35 (Minutes)

This setting don't work, I waited over night. There are nothing DDNS related in the logs (only that I activated the rule).

I know that the problem isn't a typo in the update URL or server side because it works when I copy the URL directly from the web interface, past it in a chrome browser tab on the computer that is connected to the internet over that router and hit return. 1 minute later I can "ping <myHostName>" from another computer. I also checked that the ping to the router technically worked before with "ping <IP>".

Basically the router just have to call the update URL when the IP changes (and for safety measures every 35 minutes (I think that is what "Force IP renew" should do!?)). All other settings are irrelevant for my server as far as I can tell.

What do I have to change?
by

I want to add a (maybe helpful?) bonus info:

When I call the "Custom update URL" in a browser on a PC behind the router i get the respons:
[RESPONSE] code = 200 description = Command completed successfully runtime = 0.547 queuetime = 0 EOF
And then the connection with the URL works.

1 Answer

+1 vote
by
Hi

DDNS typically does not work on mobile networks because the carrier uses Double NAT (CGNAT). In this scenario my expereince with RUT950 is that the settings never even save. Depending what you need to do, have a look at Zerotier (see packages) a free SD-WAN.

C
Best answer
by

But then, why it works when I just call the "Custom update URL" on the PC/Notebook behind the router?