7877 questions

9301 answers

14976 comments

12781 members

0 votes
108 views 6 comments
by

Been using TRB140 with factory default setting for past 9 months with a '3' unlimited data SIM. Been getting download speeds from 25 - 40Mbps. Since 12 Feb speed dropped to 1.5 - 4.5Mbps. Put the '3' SIM into the original Three supplied Huawei modem/router, and back to 30+Mbps.. put '3' SIM back into TRB140 very slow..  Took the Vodafone SIM out of my Mobile phone into the TRB140 speeds circa 25+Mbps, put the '3' SIM into the TRB, back down to circa 2Mbps.. Voda SIM back in my phone (as limited data per month) & '3' SIM now in the Huawei box and getting 25 - 40Mbps  Why is the '3' SIM so slow in the TRB140 ?

Data connection state

Connected

Connection type

4G (LTE)

Signal strength

-51 dBm

Carrier Aggregation

Single

Connected band

LTE BAND 20

RSRP

-79 dBm

RSRQ

-13 dB

1 Answer

0 votes
by
Hi,

To give you more detailed answer I would need to know this information:

- Does your operator use any PAP/CHAP authentication upon connecting with the modem where your '3' sits?

- Does it use any particular APN?

- What is the Huawei full model name? (to make sure it's not the LTE category that is higher on Huawei).

If the operator supplied you with a Huawei router - there must be something that they did to it to make them compatible, maybe they limit their users to only using supplied by them hardware?

EB.
by
Hi Ernestas, and thank you for getting back to me

The Huawei router is a B311s-220, looking at the network profile in the B311, it shows the APN as '3internet'. User name & password are blank.

The TRB140 has been working at full speed with '3' for months, something 'happened' from last weekend and now shockingly slow - without any changes being made.

P.S. I did a factory reset to the TRB140, but no joy. I states it's running on the latest firmware
by

Could you please output the insides of the file /etc/config/network and /etc/config/firewall?

Just use cat command in CLI, for example: cat /etc/config/network

EB.

by
Hi EB

Network :-

config interface 'loopback'

option ifname 'lo'

option proto 'static'

option ipaddr '127.0.0.1'

option netmask '255.0.0.0'

config globals 'globals'

option ula_prefix 'fd0c:90b6:f5a7::/48'

config interface 'lan'

option type 'bridge'

option ifname 'eth0 rndis0'

option proto 'static'

option ipaddr '192.168.2.1'

option netmask '255.255.255.0'

option ip6assign '60'

config interface 'mob1s1a1'

option proto 'connm'

option modem '3-1'

option metric '1'

option sim '1'

option pdp '1'

option ifname 'rmnet0'

option auth 'none'

option method 'nat'

option force_apn '-1'

option apn '3internet'

config device 'eth0'

option name 'eth0'

option macaddr '00:1E:42:2C:1B:E5'

Firewall :-

config defaults

option syn_flood '1'

option input 'ACCEPT'

option output 'ACCEPT'

option forward 'REJECT'

config zone

option name 'lan'

list network 'lan'

option input 'ACCEPT'

option output 'ACCEPT'

option forward 'ACCEPT'

config zone

option name 'wan'

option input 'REJECT'

option output 'ACCEPT'

option forward 'REJECT'

option masq '1'

option mtu_fix '1'

option network 'wan wan6 mob1s1a1'

config forwarding

option src 'lan'

option dest 'wan'

config rule

option name 'Allow-DHCP-Renew'

option src 'wan'

option proto 'udp'

option dest_port '68'

option target 'ACCEPT'

option family 'ipv4'

config rule

option name 'Allow-Ping'

option src 'wan'

option proto 'icmp'

option icmp_type 'echo-request'

option family 'ipv4'

option target 'ACCEPT'

config rule

option name 'Allow-IGMP'

option src 'wan'

option proto 'igmp'

option family 'ipv4'

option target 'ACCEPT'

config rule

option name 'Allow-DHCPv6'

option src 'wan'

option proto 'udp'

option src_ip 'fc00::/6'

option dest_ip 'fc00::/6'

option dest_port '546'

option family 'ipv6'

option target 'ACCEPT'

config rule

option name 'Allow-MLD'

option src 'wan'

option proto 'icmp'

option src_ip 'fe80::/10'

list icmp_type '130/0'

list icmp_type '131/0'

list icmp_type '132/0'

list icmp_type '143/0'

option family 'ipv6'

option target 'ACCEPT'

config rule

option name 'Allow-ICMPv6-Input'

option src 'wan'

option proto 'icmp'

list icmp_type 'echo-request'

list icmp_type 'echo-reply'

list icmp_type 'destination-unreachable'

list icmp_type 'packet-too-big'

list icmp_type 'time-exceeded'

list icmp_type 'bad-header'

list icmp_type 'unknown-header-type'

list icmp_type 'router-solicitation'

list icmp_type 'neighbour-solicitation'

list icmp_type 'router-advertisement'

list icmp_type 'neighbour-advertisement'

option limit '1000/sec'

option family 'ipv6'

option target 'ACCEPT'

config rule

option name 'Allow-ICMPv6-Forward'

option src 'wan'

option dest '*'

option proto 'icmp'

list icmp_type 'echo-request'

list icmp_type 'echo-reply'

list icmp_type 'destination-unreachable'

list icmp_type 'packet-too-big'

list icmp_type 'time-exceeded'

list icmp_type 'bad-header'

list icmp_type 'unknown-header-type'

option limit '1000/sec'

option family 'ipv6'

option target 'ACCEPT'

config rule

option name 'Allow-IPSec-ESP'

option src 'wan'

option dest 'lan'

option proto 'esp'

option target 'ACCEPT'

config rule

option name 'Allow-ISAKMP'

option src 'wan'

option dest 'lan'

option dest_port '500'

option proto 'udp'

option target 'ACCEPT'

config include

option path '/etc/firewall.user'

config rule

option dest_port '22'

option proto 'tcp'

option name 'Enable_SSH_WAN'

option target 'ACCEPT'

option src 'wan'

option enabled '0'

config rule

option dest_port '80'

option proto 'tcp'

option name 'Enable_HTTP_WAN'

option target 'ACCEPT'

option src 'wan'

option enabled '0'

config rule

option dest_port '443'

option proto 'tcp'

option name 'Enable_HTTPS_WAN'

option target 'ACCEPT'

option src 'wan'

option enabled '0'

config rule

option dest_port '4200-4220'

option proto 'tcp'

option name 'Enable_CLI_WAN'

option target 'ACCEPT'

option src 'wan'

config include 'pscan'

option port_scan '0'

option type 'script'

option path '/etc/port-scan-prevention.sh'

config redirect

option enabled '0'

option proto 'tcp'

option src_dport '22'

option dest_ip '127.0.0.1'

option reflection '0'

option src 'wan'

option name 'Enable_SSH_WAN_PASSTHROUGH'

option dest 'lan'

option target 'DNAT'

config redirect

option enabled '0'

option proto 'tcp'

option src_dport '80'

option dest_ip '127.0.0.1'

option reflection '0'

option src 'wan'

option name 'Enable_HTTP_WAN_PASSTHROUGH'

option dest 'lan'

option target 'DNAT'

config redirect

option enabled '0'

option proto 'tcp'

option src_dport '80'

option dest_ip '192.168.2.1'

option dest_port '80'

option src 'wan'

option name 'tlt_allow_remote_http_through_DMZ'

option target 'DNAT'

option dest 'lan'

config redirect

option enabled '0'

option proto 'tcp'

option src_dport '443'

option dest_ip '127.0.0.1'

option reflection '0'

option src 'wan'

option name 'Enable_HTTPS_WAN_PASSTHROUGH'

option dest 'lan'

option target 'DNAT'

config redirect

option enabled '0'

option proto 'tcp'

option src_dport '443'

option dest_ip '192.168.2.1'

option dest_port '443'

option src 'wan'

option name 'tlt_allow_remote_https_through_DMZ'

option target 'DNAT'

option dest 'lan'

config redirect 'E_CLI_W_P'

option enabled '0'

option proto 'tcp'

option src_dport '4200-4220'

option dest_ip '127.0.0.1'

option reflection '0'

option src 'wan'

option name 'Enable_CLI_WAN_PASSTHROUGH'

option target 'DNAT'

option dest 'lan'
by

Hi,

Could you write down: option flow_offloading '1' in firewall config right under the first option forward 'REJECT'?

You can use WinSCP file transfer app for that or just vi command inside CLI.

To connect with WinSCP use SCP protocol and your login credentials to CLI.

And to edit with vi:

- Start editing by clicking letter I

- Edit your file

- To exit editing mode press ESC

- To save and quit write :wq

And after editing the file please restart the service of the firewall with command in CLI: /etc/init.d/firewall restart

EB.

by

Hi EB

Made the change, no change to speed though (speedtest.net) shows about 3-5Mbps download, just beforehand in the Huawei box 50-55Mbps !



root@Teltonika-TRB140:~# cat /etc/config/firewall
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option flow_offloading '1'
by
Then what I could suggest is calling that operator and asking them for a new SIM, maybe a new SIM will help your situation. But as every other SIM works normally there's nothing that comes in my mind that could somehow interrupt the normal work of that '3' SIM.

EB.