10947 questions

13051 answers


27732 members

+1 vote
343 views 3 comments
I have a backup configuration file made using the same release of the firmware (RUT9XX_R_00.06.07.5).

When I try to use the restore configuration option, I choose a file and it is shown next to the Choose file button, however when I press the upload archive button I get the response no file chosen.

I have used the procedure  on previous firmware versions and it works.

Can you please let me know what the problem is.


agreed, I have exactly the same issue, when you select a previously made back up even from this specific Teltonika rut955 and then try to restore it you get the error "no file selected please select a file"

I have checked I am on identical firmware and as we have approx. 50 rut955's I have tried this on multiple devices and after the latest firmware you can not restore any backup configs made with .5 however if I use firmwares from older device firmwares to devices with identical firmware it still works fine.

Glad its not just me

I'm also having the same problem RUT950 FW ver.: RUT9XX_R_00.06.07.5.  Its the java script "upload-validation.js" and the check file size function returns false so it will never upload.

Also the user default does not work and there are issues with the Dynamic DNS not fucntioning with the new firmeware.  If its working for you please advise the steps.

Still an issue in FW 06.07.7

2 Answers

0 votes

We had this query in the forum before, but I'm still not able to reproduce the issue.

Could you please give me this information:

- Full product name of RUT9 router you're using

- Have you tried clearing your browser's cache and cookies?

- Have you tried resetting the device and doing it again?

- When you download the backup, what is the extension of the file? Is it tar.gz?

- Could you please upload a good quality screenshot of the error you're getting?

0 votes


I managed to get the following response from our local service agent. Hope it helps.

Ah, I see there must be a problem in that firmware release in the web user interface.  I will report the problem to them.  You can work around this via CLI until Teltonika fixes it.


Use an SCP program to copy the backup to the RUT, for example from Linux/Mac SSH utility (you can also use WinSCP GUI if on Windows)

scp backup-*.tar.gz root@


SSH into the Teltonika and run:

sysupgrade -r /tmp/backup-*.tar.gz