subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
2,630 views 9 comments
on my trb142 the ntrip client doesn't work.

FW ver: TRB14X_R_00.00.11

in CLI i can't find the ntrip client.

Is there an ne FW?

2 Answers

+1 vote
After long time of searching for the problem, we have solved it.

Teltonika has forgotten the file /etc/init.d/ntrip

We have tried the file vom the rut955. Please fix it in the following FW.

Best regards from germany
Best answer
by anonymous

Thanks for sharing this information. Details are provided to Telotnika RND and the next FW release should be available in the upcoming week.
Please include Strings as NTrip. IPs are good. IPs and Strings are better.

Using an ntrip caster behind a dyndns needs strings.

I think a good thing will be to include a funtion to send a NMEA String from RS232-Input to the Ntrip Caster. It is neccessary for using an Virtual Reference Station.
0 votes
by anonymous

Today I found a new Firmware in your Wiki: TRB1420_R_00.01.00

I hoped, you will fix the ntrip problem, but the new firmware has the same issue.

Actually I see 3 problems with the TRB142

First of all is the missing file /ect/init.d/ntrip.

The second one is, that you can't use an internetadresse für the ntrip server. Using an IP is not enough.

The third problem is, that the TRB can't send a NMEA position from the rs232 to the NTRIP Server.

All three problems are not solved in the new Firmware.

I know, it's a linux system. Do you think the users have to fix it for themself? The first is easy to fix. German speaking users can find the solution on but the other problems?

by anonymous

Sorry to hear about the issue. TRBs are currently under development, we're doing fixes, improvements and constantly adding new features, so a single issue fix does not always take the highest priority.

I'll open a ticket for this bug (or bugs, rather) and more information would help resolve this sooner. The first two issues seem simple enough, but the third one is vague. Can you reproduce the issue, download the Troubleshoot file and upload it here for analysis?
Same problems here, absolutely reproduceable, but since it does nothing, there are also no error messages which you are asking for.

Simply tell the developers to test their code at last a single time!

Third Problem isn't quite an issue, but a lack of functionality. The TRB should receive NMEA-GGA sentences from an external GPS and transmit them instead of the fixed location to the caster, in order to work properly as vitual reference station client.
Any ideas when this will be rectified? I've got 4 of these and I need them to work!
by anonymous
The new release will be out this week.
by anonymous
which week? since today it is a new week
by anonymous
by anonymous
Yes, I have installed it yesterday. It seems to be very good.

Thank you