7591 questions

9029 answers

14584 comments

11836 members

0 votes
61 views 0 comments
by

I tried to compile SDK RUT9XX_R_GPL_00.06.07.5.tar but got errors:

make[4]: Entering directory '/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/tools/automake'

# remove old automake resources to avoid version conflicts rm -rf

/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/staging_dir/host/share/aclocal-[0-9]* rm -rf

/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/staging_dir/host/share/automake-[0-9]* make -C

/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/build_dir/host/automake-1.15.1 install

make[5]: Entering directory '/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/build_dir/host/automake-1.15.1'

restore=: && backupdir=".am$$" && \ am__cwd=`pwd` && CDPATH="${ZSH_VERSION+.}:" && cd . && \

rm -rf $backupdir && mkdir $backupdir && \ if (/bin/bash

/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/build_dir/host/automake-1.15.1/lib/missing makeinfo --version) >/dev/null 2>&1; then \

  for f in doc/automake.info doc/automake.info-[0-9] doc/automake.info-[0-9][0-9] doc/automake.i[0-9] doc/automake.i[0-9][0-9]; do \ if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \  done; \ else :; fi && \ cd "$am__cwd"; \ if /bin/bash

/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/build_dir/host/automake-1.15.1/lib/missing makeinfo   -I doc -I ./doc \  -o doc/automake.info ./doc/automake.texi; \ then \  rc=0; \ CDPATH="${ZSH_VERSION+.}:" && cd .; \ else \  rc=$?; \ CDPATH="${ZSH_VERSION+.}:" && cd . && \

  $restore $backupdir/* `echo "./doc/automake.info" | sed 's|[^/]*$||'`; \ fi; \rm -rf $backupdir; exit $rc

/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/build_dir/host/automake-1.15.1/lib/missing: line 81: makeinfo: command not found

WARNING: 'makeinfo' is missing on your system.

         You should only need it if you modified a '.texi' file, or

         any other file indirectly affecting the aspect of the manual.

         You might want to install the Texinfo package:

         <http://www.gnu.org/software/texinfo/>

         The spurious makeinfo call might also be the consequence of

         using a buggy 'make' (AIX, DU, IRIX), in which case you might

         want to install GNU make:

         <http://www.gnu.org/software/make/>

Makefile:2518: recipe for target 'doc/automake.info' failed

make[5]: *** [doc/automake.info] Error 127

make[5]: Leaving directory '

/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/build_dir/host/automake-1.15.1'

Makefile:50: recipe for target '/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/staging_dir/host/stamp/.automake_installed' failedmake[4]: *** [/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/staging_dir/host/stamp/.automake_installed] Error 2make[4]: Leaving directory '/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/tools/automake'tools/Makefile:159: recipe for target 'tools/automake/install' failed

make[3]: *** [tools/automake/install] Error 2

make[3]: Leaving directory '/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5'

tools/Makefile:158: recipe for target '/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/staging_dir/target-mips_34kc_uClibc-0.9.33.2/stamp/.tools_install_yynyynynynyyyyyyyyyyyyyyyyyyyyynyyyynnyyynyyyynnynyyyy' failed

make[2]: *** [/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5/staging_dir/target-mips_34kc_uClibc-0.9.33.2/stamp/.tools_install_yynyynynynyyyyyyyyyyyyyyyyyyyyynyyyynnyyynyyyynnynyyyy] Error 2 make[2]: Leaving directory '

/home/nik/Desktop/RUT9XX_R_GPL_00.06.07.5'

Makefile:95: recipe for target 'world' failed

The same result - with any config. Mostly I was interested in defconfig to get a basic fw. I used ubuntu-16.04.7-desktop-amd64 and ubuntu-18.04.5-desktop-amd64 installed on VM. Produced recommended procedures and installed all needed packages for SDK:

sudo apt-get update

sudo apt-get install -y build-essential curl devscripts gawk gcc-multilib gengetopt gettext git groff file flex libncurses5-dev libssl-dev python2.7 subversion unzip vim-common zlib1g-dev wget

Initially I am interested to get a basic fw (with defconfig) before starting developing any options.

What am I doing wrong?

1 Answer

0 votes
by

Hello,

I have just successfully compiled the latest RUT9XX_R_00.06.07.5 GPL using Ubuntu 16.04 OS and installing exactly the same packages that are required for SDK to work (full guide: https://wiki.teltonika-networks.com/view/RUT_Software_Development_Kit_instructions).

I have managed to accomplish that on the second attempt (first try my VM ran out of space). 

I have analyzed your error and I would suggest double-checking if all the required packages were installed successfully. Also, how do you initialize compiling process? By simply using the command make V=s or you make menu config first? Have you changed anything in SDK? Is there enough free recources in your virtual machine?

Regards.