7953 questions

9404 answers

15104 comments

12982 members

0 votes
548 views 4 comments
by
I have set up rut950 as a openvpn tun server.

rut950 ip is 10.10.1.1

Virtual network is 10.10.10.0/24

I have push route 10.10.1.0 255.255.255.0 in server config.

Connected to the switch on the rut950 is a windows laptop, it gets ip 10.10.1.175

from cli in rut950 i can ping 10.10.1.175

I connect to openvpn server from a windows 10 with openvpn client, and connection is established.

From the client i can ping 10.10.10.1 and 10.10.1.1 and i can open the web gui at 10.10.1.1 but 10.10.1.175 does not respond to ping.

As per the documentation I havent touched the firewall.

Is there something more I need to do than push the route to reach LAN behind openvpn server?

Thanks for your time

1 Answer

0 votes
by

Hello,

If I do understand correctly, you do have 1 server (RUT950) and 2 clients (windows laptop 10.10.1.175 and another PC client that you want to use to ping the first client). To reach a client from a client you must enable Client to Client communication. You can read more about that here: https://wiki.teltonika-networks.com/view/OpenVPN_configuration_examples#Client_to_Client

Also, there may be an issue with Windows firewall, try to test if communication goes through with Windows Firewall disabled.

Regards.

by
Hello, thanks for anwering

No, There is only one vpn client. 10.10.1.175 is physically connected to the built in switch in rut950

best regards
by
You have mentioned that you can reach 10.10.1.175 from the router, but then you can't ping the client from exactly where (from itself)?

Also, have you tried disabling firewalls in the devices to check?

Regards.
by
Thanks for your patience!

I'll try some ascii topolgy:

Laptop A with Windows VPN-client ip 192.168.1.181
VPN-adapter 10.10.10.6
 t
 u
 n
 n
 e
 l
VPN server adapter 10.10.10.1
RUT950 ip 10.10.1.1
|
|
local-lan
|
|
laptop B ip 10.10.1.175 (from rut dhcp)

My goal is to reach laptop B from laptop A via the tunnel

I can ping laptop B From RUT 10.10.1.1

I can connect to RUT web interface from laptop B

I can establish a vpn-connection from laptop A to RUT, then from laptop A, ping 10.10.10.1 ok, ping 10.10.1.1 ok, connect to web interface at 10.10.1.1 ok

but i cannot reach laptop B. I have tried with firewall disabled on laptop B, I have connected other devices to local-lan 10.10.1.0 that have no firewalls (PLC's) still no luck.

best regards
ago by

Hi there,

did you solve your issue?
I am stuck at the exactly same point. My topology is exactly like yours. Except I'm using a RUT300.
I can connect via OpenVPN from outside and ping the RUT300 on it's ovpn server address and open the WebGUI as well.
But I cannot ping any device connected directly to the lan interface. I cannot ping the RUT300 itself on its lan address.  

Maybe a member of Teltonika can help me with this?


Outline on my Topology (with my currently configured ip addresses):

Windows Client 1 (lan ip:  192.168.12.235 | ovpn adapter ip: 10.19.99.6)
|
| openvpn tunnel
|
RUT300 (WAN: 192.168.12.99 | LAN: 192.168.0.1 | OVPN: 10.19.99.1)
|
| wired lan, connected to port LAN1 on RUT300
|
Windows Client 2 (lan ip: 192.168.0.100)

Observations / status quo:
Client 1 can ping: 10.19.99.1
Client 1 can ping: 192.168.0.1
Client 1 cannot ping: 192.168.0.100

Client 2 can ping: 10.19.99.1
Client 2 can ping: 192.168.0.1
Client 2 cannot ping: 10.19.99.6

RUT300 can ping: 192.168.0.100
RUT300 cannot ping: 10.19.99.6


I checked all the routes on the RUT300 and the Client 1. They seem to be correct.
Therefore I think I missed a firewall setting.

Thank you all out there for help!