7141 questions

8568 answers

13830 comments

10608 members

0 votes
76 views 2 comments
by
Hi, I have packaged my c program which depends on mosquitto v. 2.0.10. However, I am not able to update from mosquitto v. 1.4.15 using opkg update mosquitto. How can I update to at least a version which supports MQTT v.3.1.1?

Thomas
by
Update: mosquitto 1.4 does support mqtt3.1.1 just not by default. However, would still be nice to use latest version.

1 Answer

0 votes
by
Hello,

Thank you for contacting.

May i know what device are you using ?

What is the firmware on device ?

Have you tried upgrading to the latest?

https://wiki.teltonika-networks.com/view/FW_%26_SDK_Downloads

If you are able to find the package file online.

You can try this :

https://wiki.teltonika-networks.com/view/RUT955_Package_Manager#Custom_package_upload

Thanks.

Regards,

Ahmed
by

Further if you use the following command , you will be able to see the available versions for mosquitto. 

root@Teltonika-RUT240:~# opkg list |grep mosquitto

libmosquitto - 1.4.7-1 - Library required for mosquitto's command line client tools, also for use by any third party software that wants to communicate with a mosquitto server.  Should be useable for communicating with any MQTT v3.1/3.1.1 compatible server, such as IBM's RSMB, in addition to Mosquitto This package is built with SSL support

libmosquitto-nossl - 1.4.7-1 - Library required for mosquitto's command line client tools, also for use by any third party software that wants to communicate with a mosquitto server.  Should be useable for communicating with any MQTT v3.1/3.1.1 compatible server, such as IBM's RSMB, in addition to Mosquitto This package is built without SSL support

libmosquitto-ssl - 1.4.15-3

lua-mosquitto - 0.1-1 - Lua bindings to libmosquitto

luci-app-mosquitto - trunk+svn+teltonika+u1-1

mosquitto - 1.4.7-1 - Mosquitto is an open source (BSD licensed) message broker that implements the MQTT protocol version 3.1 and 3.1.1. MQTT provides a lightweight method of carrying out messaging using a publish/subscribe model.  This package also includes some basic support for configuring via UCI This package is built with SSL support

mosquitto-client - 1.4.7-1 - Command line client tools for publishing messages to MQTT servers and subscribing to topics. This package is built with SSL support

mosquitto-client-nossl - 1.4.7-1 - Command line client tools for publishing messages to MQTT servers and subscribing to topics. This package is built without SSL support

mosquitto-nossl - 1.4.7-1 - Mosquitto is an open source (BSD licensed) message broker that implements the MQTT protocol version 3.1 and 3.1.1. MQTT provides a lightweight method of carrying out messaging using a publish/subscribe model.  This package also includes some basic support for configuring via UCI This package is built WITHOUT SSL support.

mosquitto-ssl - 1.4.15-3

Thanks