6734 questions

8109 answers

13203 comments

9430 members

0 votes
61 views 4 comments
by
I have an RUTX11 (Firmware Version: RUTX_R_00.02.05.2) and would like to configure it's 2.4MHz WiFi as a client and have it connect to an AP on another embedded Debian Linux system I have.

On the RUTX11 side, I've configured the device to be a client under /Network/Wireless/WiFi 2.4 GHz and supplied the ESSID and the WPA2-PSK password of my AP.  The wireless status page shows both the Device Status and Interface Status as running.

My Debian AP shows the RUTX11 wlan0 MAC as being authenticated and syslog shows that the RUTX11 wlan0 MAC is completing the group key handshake every 10 minutes, along with it's other clients. So far so good.

Under /Network/Interfaces, I configured WWAN to use DHCP and, under Physical Settings, set the interface to wlan0 and did a Save and Apply.

However, DHCP request packets from the RUTX11 go out the wlan0 interface (as seen via tcpdump), but they do not arrive at the Debian Linux box, and so the RUTX11 does not get an IP address.  Other clients are able to obtain an IP address from the Debian box.

Using a static IP address does not seem to work either, as pings are unsuccessful.from either side of the interface. In this case, /Network/Interfaces/WWAN status is running and the Rx and Tx byte counts are increasing.

I have turned off the firewalls on both the Debian and RUTX11 machines, to no avail.

This is such a simple function, I know I must have some problem with my configuration, but it is unclear to me what that is.

Any help would be appreciated.

jw

1 Answer

0 votes
by
Hi,

First of all, please update your RUTX11 to the latest firmware version.

Second of all, try resetting the device afterwards to the factory default settings.

Lastly, please check if the IP addresses do not mix-up, if the reason you're using RUTX11 is to extend the network it is important to check that DHCP servers on both sides do not use the same subnet.

EB.
by

Thank you for the response.  Taking the suggestions in reverse order:

IP Addressing

I should have mentioned that the RUTX11 LAN address is the default 192.168.1.1/24.  The AP I would like it to connect to uses the 192.168.101.0/24 subnet, and its DHCP server hands out addresses on that subnet.  So there should be no conflict with the addressing

Factory Default Settings

I've tried both static addressing and DHCP and have restored the factory defaults in between the most recent test iterations and still see the same misbehavior.

Firmware Update Fails

This morning I have downloaded RUTX_R_00.02.06.1_WEBUI.bin (from https://wiki.teltonika-networks.com/view/RUTX11_Firmware_Downloads) and then used /System/Firmware/Update Firmware to try to update the firmware to the latest version. The file is uploaded and validated, and I clicked on Proceed and after the reboot, the firmware version reported on the WEBUI remains unchanged at RUTX_R_00.02.05.2.  I have repeated this procedure a half dozen times with the same result.

by
Please try reinstalling the firmware through the bootloader menu.

https://wiki.teltonika-networks.com/view/RUTX09_Device_Recovery_Options#Bootloader_menu

EB.
by
Just to close the loop on this one:

Reinstalling the firmware through the bootloader menu did not work.

So to recap:

1. WiFi Client mode does not work

2. Updating the firmware via the standard route did not work

3. Updating the firmware via the bootloader menu did not work.

I was evaluating the RUTX11 for possible use by my company as the computer for our next version.

As we say in my country: Three strikes and you're out.
by

Hello,

Sorry for the late reply, could you explain in more detail how did it not work for you? What error did you get?

If even after bootloader menu firmware flashing you're still on 02.05.1 version - please do this:

1. In CLI type firstboot and proceed with reset procedure of the command.

2. After it's done go to bootloader menu again and try reinstalling 02.06.1 firmware again.

EB.