6385 questions

7716 answers

12530 comments

8398 members

0 votes
13 views 2 comments
by

Hello I'm having problems in compiling RUTX_R_GPL_00.02.06.1 on Ubuntu and it always gets stuck to libcgi

I saw the GitHub repository https://github.com/rafaelsteil/libcgi.git/ results in a 301 redirect to https://github.com/rafaelsteil/libcgi/ and that seems to mess up the compilation. I tried to edit the Makefile with the new URL but still not working.

Can you please try to compile this software and see if you have the same error? 

Please advise asap, it's very urgent for our project

Thanks

Details of error:

mkdir -p /home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/dl

SHELL= flock /home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/tmp/.libcgi-1.3.0.tar.xz.flock -c '   /home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/scripts/dl_github_archive.py --dl-dir="/home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/dl" --url="https://github.com/rafaelsteil/libcgi.git" --version="1d2928626fd42abab07440df24d62f101455e50c" --subdir="libcgi-1.3.0" --source="libcgi-1.3.0.tar.xz" --hash="x" || ( echo "Checking out files from the git repository..."; mkdir -p /home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/tmp/dl && cd /home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/tmp/dl && rm -rf libcgi-1.3.0 && [ \! -d libcgi-1.3.0 ] && git clone  https://github.com/rafaelsteil/libcgi.git libcgi-1.3.0 && (cd libcgi-1.3.0 && git checkout 1d2928626fd42abab07440df24d62f101455e50c && git submodule update --init --recursive) && echo "Packing checkout..." && export TAR_TIMESTAMP=`cd libcgi-1.3.0 && git log -1 --format='\''@%ct'\''` && rm -rf libcgi-1.3.0/.git && tar --numeric-owner --owner=0 --group=0 --mode=a-s --sort=name ${TAR_TIMESTAMP:+--mtime="$TAR_TIMESTAMP"} -c libcgi-1.3.0 | xz -zc -7e > /home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/tmp/dl/libcgi-1.3.0.tar.xz && mv /home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/tmp/dl/libcgi-1.3.0.tar.xz /home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/dl/ && rm -rf libcgi-1.3.0; );     '

libcgi-1.3.0.tar.xz: Download from https://github.com/rafaelsteil/libcgi.git failed

libcgi-1.3.0.tar.xz: Requires sha256sum for verification

Checking out files from the git repository...

Cloning into 'libcgi-1.3.0'...

fatal: unable to access 'https://github.com/rafaelsteil/libcgi.git/': gnutls_handshake() failed: Close notify

make[4]: *** [/home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/dl/libcgi-1.3.0.tar.xz] Error 128

make[4]: Leaving directory `/home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/package/libs/libcgi'

time: package/libs/libcgi/compile#0.12#0.09#0.33

make[3]: *** [package/libs/libcgi/compile] Error 2

make[3]: Leaving directory `/home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64'

make[2]: *** [/home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_compile] Error 2

make[2]: Leaving directory `/home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64'

make[1]: *** [world] Error 2

make[1]: Leaving directory `/home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64'

make: *** [world] Error 2

by
I also tried to edit the /home/parallels/RUTX_02.06.1/openwrt-gpl-ipq40xx-generic.Linux-x86_64/scripts/dl_github_archive.py script to disable hash checking but I think there is a bigger underlying issue with the versions. Please let me know asap thanks!

1 Answer

0 votes
by
Hello,

Works for me. errno 128 is EKEYREVOKED, you have something strange in your distribution.

I'll send you the libcgi-1.3.0.tar.xz, put it in the dl directory.

Regards,
ago by
Hi ok thanks. I tried again on a Debian 10 machine and seems to have worked. I let you know If I spot any other issue thanks!