7141 questions

8568 answers

13830 comments

10608 members

0 votes
45 views 1 comments
by
I'm using an RUT955 with the latest firmware.

I'm trying to get SMS control of OpenVPN to work. I want it to connect on SMS, and disconnect on SMS.

I can send it "vpnon client_001" and it will *enable* the client - but it does not connect. If I use RMS to log in and hit save, it connects.

I can send it "vpnoff client_001" and it will *disable* the client - but it does not disconnect. If I use RMS to log in and hit save, it disconnects.

If i send the SMS, then send a reboot SMS, it works - but I don't want it rebooting because the LAN ports are in use.

Anyone know how to make it behave?

1 Answer

0 votes
by
Hello,

Thank you very much for your discovery, I managed to reproduce this issue myself and I will report it to our RnD department.

Best regards.
by
Hi

I can confirm the same behaviour on RUT240 with firmware RUT2XX_R_00.01.14. Sending SMS, vpnoff <name> will remove the check in Enabled under OpenVPN Configuration for the tunnel name, but openvpn is still running until "Save" is pressed

Regards Ivan