10512 questions

12517 answers

19445 comments

22043 members

0 votes
157 views 2 comments
by
I'm using an RUT955 with the latest firmware.

I'm trying to get SMS control of OpenVPN to work. I want it to connect on SMS, and disconnect on SMS.

I can send it "vpnon client_001" and it will *enable* the client - but it does not connect. If I use RMS to log in and hit save, it connects.

I can send it "vpnoff client_001" and it will *disable* the client - but it does not disconnect. If I use RMS to log in and hit save, it disconnects.

If i send the SMS, then send a reboot SMS, it works - but I don't want it rebooting because the LAN ports are in use.

Anyone know how to make it behave?

1 Answer

0 votes
by
Hello,

Thank you very much for your discovery, I managed to reproduce this issue myself and I will report it to our RnD department.

Best regards.
by
Hi

I can confirm the same behaviour on RUT240 with firmware RUT2XX_R_00.01.14. Sending SMS, vpnoff <name> will remove the check in Enabled under OpenVPN Configuration for the tunnel name, but openvpn is still running until "Save" is pressed

Regards Ivan
by
I have also experienced this on RUT950s with firmware 6.08.3 where some work as required ad some don't. I have managed to locate the 'cause' by examining the configuration of units which were working and ones that were not. Those that worked were ones that had been upgraded to 6.08.03 those that did not work were newly configured ones. Using CLI I examined the Openvpn configuration section (uci show openvpn) and found on the ones that worked as described above (i.e. don't connect) there was an branch 'openvpn.teltonika_auth_service' presumably related to RMS (which we don't use). This was not present on the ones that worked correctly after receiving the VPNON / VPNOFF sms messages. Deleting this section on the ones that didn't work cured the issue. I am not sure what the implications of removing that section are if you are using RMS perhaps a modification to that section may be forthcoming from support to resolve the issue without deleting the section. Hope this helps.