8384 questions

9850 answers

15651 comments

14097 members

0 votes
138 views 5 comments
by

Hello Teltonika team,

I have a RUT360 and complied hotspot function, it is working well. I was able to launch the internal landing page by mac authentication, however, the speed is very slow.

The network topology: gateway——RUT360-----mobile phone (or laptop)

I can get around 52Mbps download and 51Mbps download speed based Wireless LAN 192.1681.1, but I can only get the maximum 9~10Mbps download and 5~7Mbps upload speed based on Hotspot LAN 192.168.2.1

chilli.@group[0]=group

chilli.@group[0].name='default'

chilli.@chilli[0]=chilli

chilli.@chilli[0].enabled='0'

chilli.@chilli[0].dns2='8.8.4.4'

chilli.@chilli[0].ipdown='/etc/chilli/down.sh'

chilli.@chilli[0]._mode='local'

chilli.@chilli[0].ipup='/etc/chilli/up.sh'

chilli.@chilli[0].uamlogoutip='1.0.0.0'

chilli.@chilli[0].uamlisten='192.168.2.254'

chilli.@chilli[0].network='wifi1'

chilli.@chilli[0].radiusauthport='1812'

chilli.@chilli[0].net='192.168.2.0/24'

chilli.@chilli[0].radiusacctport='1813'

chilli.@chilli[0]._protocol='http'

chilli.@chilli[0]._landingpage='int'

chilli.@chilli[0]._success='uam'

chilli.@chilli[0].usersdbpath='/etc/chilli/users.db'

chilli.@chilli[0].dbpath='/var/hotspot.db'

chilli.@chilli[0].uamport='3990'

chilli.@chilli[0].dns1='8.8.8.8'

Thank you

1 Answer

0 votes
by
Hi,

Please take a look at user groups and their limits, it could be that you need to create a new user group and set its limit to unlimited on bandwidth.

https://wiki.teltonika-networks.com/view/RUT360_Hotspot#User_Groups

Also, are you connecting to the hotspot with the same device that had a good quality wifi speed on wireless lan?

EB.
by
Hi, I confirm that there is no limits for user group, it is fully unlimited.

Yes, I can get good speed (50~52Mbps) on Wireless LAN, just got low speed (9~10Mbps) on Hotspot LAN. I tested via mobile phone and laptop got the same result. The hotspot LAN is connected to tun0, once I do speedtest, the CPU will be loading 100%.

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00

          inet addr:192.168.2.254  P-t-P:192.168.2.254  Mask:255.255.255.0

          inet6 addr: fe80::eb8c:b7e5:a2d1:4580/64 Scope:Link

          UP POINTOPOINT RUNNING  MTU:1500  Metric:1

          RX packets:109203 errors:0 dropped:0 overruns:0 frame:0

          TX packets:156401 errors:0 dropped:51524 overruns:0 carrier:0

          collisions:0 txqueuelen:100

          RX bytes:13630308 (12.9 MiB)  TX bytes:166404204 (158.6 MiB)

Thank you
by
Thank you.

Could you also give me the version of the firmware that is installed on RUT360?

EB.
by
RUT36X_00.02.06.1
by
I see that 7.0 base firmware should officially include hotspot in the package manager, as you're installing hotspot from SDK it could be that it's not yet prepared for normal use and that's why you're encountering these issues.

What I would suggest is waiting for a new firmware release and then let's see if the issue reappears again, this way I will be able to point at it to our RnD department and get you a quick fix.

EB.
by
okay, thank you.