10934 questions

13039 answers

20335 comments

27479 members

+2 votes
767 views 11 comments
by
Hi there, I have read the post re 'GPS usage with RUTX11' which provides some information but I cannot seem to get the GPS tracking to work on Ruhavik. I have created a user account and when I create a unit it provides a server host in ip and dns formats (tried both) and a port which I entered into NMEA forwarding my router but they don't communicate and I get a message trying to connect? Unsure of  NMEA collecting should be enabled and what location should be and also NMEA Sentence settings? Appreciate any assistance you can provide. Kind regards Tony
by
Hi again,

Many thanks for the ongoing support.
I understand now that I do not have to us a usb drive.
I am still unsure how to source the correct network or public IP Address.  Should this be provided RUHAVIK?
Also Re your question "have you checked if you are putting the correct IP address and this IP address is reachable by Rutx11 ?"

How can I do this?


Kind regards Tony

2 Answers

+2 votes
by
Hello,

Thank you for contacting.

First of all its best to upgrade device to the latest firmware in case its not on latest.

Latest could be downloaded here:

https://wiki.teltonika-networks.com/view/RUTX11_Firmware_Downloads

Further you need to enable NMEA collecting to enable service itself. More details could be seen here:

https://wiki.teltonika-networks.com/view/RUTX11_GPS#NMEA_collecting

For NMEA sentence settings you can configure what NMEA sentences will be forwarded and collected . Details are as below:

https://wiki.teltonika-networks.com/view/RUTX11_GPS#NMEA_collecting

Thanks.

Regards,

Ahmed
by
Hi Ahmed,

Many thanks for your email and details.

Re NMEA Collecting.

The file path location. What details do I put in here and where is the collection stored?

Do I have to insert a usb storage device and if so how can I determine the file path?

Appreciate further advice please.

Kind regards Tony
by

Hello,

Yes you have to put USB storage device . But for sending data to server its not necessary . You just need to enable the sentences in NMEA sentence settings

For determining the file path:

Location must be prefixed with "/mnt/ to avoid wear out of device flash.

Also have you checked if you are putting the correct IP address and this IP address is reachable by Rutx11 ?

Thanks .

by
Hi Ahmed,

Many thanks for your email but I am still having issues. I apologise for not being to knowledgeable in this area and appreciate any assistance you can further provide. The Ruhavik server is staying still connecting when I insert the URL they supply as an IP address and the port after providing my device type and my IMEI No.

I have activated NMEA Collecting but I am unsure of exactly what to do with the Location.

Do I need to use a UBS dive even though I m only sending data to the server?

The Location do I just insert the text "mnt/to" without the quote marks or is there further detail I need to insert?

I have turned on all the switches for the NMEA Sentence Settings Forwarding Enabled and Collection Enabled and left the default intervals.

I am unsure how to check if I am putting in the correct IP Address and if it is reachable by the RUTX11?

I am using the ip address provided by Rhavik?

My apologies for having to contact you again.

Kind regards Tony
by

Hello,

You can ask things until its clear and the solution is not working as per your requirements. 

For the GPS data sending you its not mandatory to attach any usb device. 

For the IP address if its somewhere outside the network it should be Public IP address. 

https://wiki.teltonika-networks.com/wikibase/index.php?title=Private_and_Public_IP_Addresses&veaction=edit&mobileaction=toggle_view_desktop

Further check the attach image  for the NMEA enabling . 

Thanks. 

by
Hello,

You need to check the server address/IP address of the Rhavik . You can check it on Rhavik itself.

USB is not must to send the data to the server and also not must if you are not sending the data .

https://wiki.teltonika-networks.com/view/Private_and_Public_IP_Addresses

Thanks.
+1 vote
by
Hello Teltonika Team,

my understanding is that your answers to Tshep did not lead into a working system. I do have the same problem. GPS is enabled, NMEA server is registered (the one provided by RUHAVIK), NMEA collecting is on (w/o USB), GPSMRC collecting and forwarding is on. GPS-tracing via RUHAVIK doesn´t work. Any tipps?

Kind regards, Alex
by
Hi there,

I was never able to get this to work before going away but are now back from my trip. Could you please provide more details on how I can get my RUTX11 connected to RUHAVIK. Also Alex above is also after details on the same issue unless he has sorted it.

Kind regards

T
by
Hi,

Is there now a way to connect the rutx11 or another RutX.. to Ruhavik?

Regards

CJ
by
Hi Alex, really disappointed that I could never get this to work. Support from Teltonika was also not forthcoming to make it function. I would still like it to work do hopefully your interest as well will prompt support to provide the technical info we require.

T
by
Hi T,

I solved the Problem and now its working on my RUTx14 so I think the Rutx11 will also work:

I show u my config on the RUTx14:

Service -> GPS -> NMEA

Forwarding: off

NMEA Forwarding Cache:

Flash Memory

File: /mnt/gpscache

NMEA Collecting: ON

File: /mnt/gps

NMEA Sentence Settings:

Forwarding and collecting on all Positions "on" except PQGSV and PQGSA

all Interval settings: 900 (its enough for me, maybe I will increase the time a bit more)

Service -> GPS -> AVL

Enable: ON

Retry on Fail: ON

hostname /protocol / port as shown in Ruhavik

Don't contain Connection: ON

Main Rule (what ever u prefer) mine is :

Low / 300 / 20 / 900 (but u can use others)

TAVL Settings : Signal / Mobile: ON

and it works pretty good, except, the time stamp in Ruhavik is exact 2 hours in front of our local time.

cheers
by
Many thanks cjchaos for your details on how to connect my RUTX11 to Ruhavik.

Your instructions were perfect and it is working great. I even have the correct local time : )

Really appreciate you taking the time to send through the correct settings.

Kind regards T